core-common
Classes
Name | Description | |
---|---|---|
AdditionalTransform | Additional Transform implementation. | |
AffineTransform | The equations are: | |
AmbientLight | Describes the ambient light associated with a LightSettings. | |
AnalysisStyle | As part of a DisplayStyleSettings, describes how to animate meshes in the view that have been augmented with | |
AnalysisStyleDisplacement | Describes how an AnalysisStyle deforms a Polyface by applying translation to its vertices. | |
AnalysisStyleThematic | Describes how an AnalysisStyle recolors Polyface vertices by mapping values of type | |
BackendError | ||
BackgroundMapProvider | Describes one of a small set of standard, known suppliers of background map imagery as part of a BaseMapLayerSettings. | |
BackgroundMapSettings | As part of a DisplayStyleSettings, controls aspects of how the background map is displayed. | |
BaseMapLayerSettings | A ImageMapLayerSettings that can serve as the base layer for a MapImagerySettings. | |
BentleyCloudRpcConfiguration | Operating parameters for Bentley cloud RPC interface deployments. | Beta |
BentleyCloudRpcManager | Coordinates usage of RPC interfaces for Bentley cloud deployments. | Beta |
BentleyError | Base exception class for iTwin.js exceptions. | |
BlobOptionsBuilder | Beta | |
BlobReader | Beta | |
BoundingSphere | Describes a spherical volume of space as an approximation of the shape of some more complex geometric entity fully contained within that volume. | |
Camera | The current position (eyepoint), lens angle, and focus distance of a camera. | |
Carto2DDegrees | A 2D cartographic point in degrees | |
Cartographic | A position on the earth defined by longitude, latitude, and height above the WGS84 ellipsoid. | |
CartographicRange | A cartographic range representing a rectangular region if low longitude/latitude > high then area crossing seam is indicated. | |
ClipStyle | Describes symbology and behavior applied to a ClipVector when applied to a ViewState or ModelClipGroup. | |
CloudStorageCache | Beta | |
CloudStorageTileCache | Beta | |
Code | A three-part structure containing information about the Code of an Element | |
CodeSpec | A Code Specification captures the rules for encoding and decoding significant business information into | |
ColorDef | An immutable integer representation of a color. | |
ContextRealityModel | A reality model not associated with a GeometricModel but instead defined in a DisplayStyle or DisplayStyleState. | |
ContextRealityModels | A list of ContextRealityModels attached to a DisplayStyleSettings. | |
CutStyle | As part of a ClipStyle, describes how section-cut graphics should be displayed. | |
DbQueryError | ||
DisplayStyle3dSettings | Provides access to the settings defined by a DisplayStyle3d or DisplayStyle3dState, and ensures that | |
DisplayStyleSettings | Provides access to the settings defined by a DisplayStyle or DisplayStyleState, and ensures that | |
EcefLocation | The position and orientation of an iModel on the earth in ECEF (Earth Centered Earth Fixed) coordinates | |
ECJsNames | Utility to format ECProperty names according to the iTwin.js formatting rules. | |
ECSqlReader | Beta | |
EmptyLocalization | An empty Localization used if one is not provided to IModelApp. | |
EntityMetaData | Metadata for an Entity. | Beta |
Environment | As part of a DisplayStyle3dSettings, controls the display of a SkyBox and GroundPlane to simulate the | |
Feature | Describes a discrete entity within a batched RenderGraphic that can be | |
FeatureAppearance | Defines overrides for selected aspects of a Feature's symbology. | |
FeatureOverrides | Specifies how to customize the appearance of individual Features, typically within the context of a Viewport. | |
FeatureTable | Defines a look-up table for Features within a batched RenderGraphic. | |
FontMap | A FontMap holds the set of font names available in an iModel. | |
FresnelSettings | As part of a LightSettings, describes how to apply a Fresnel effect to the contents of the view. | |
Frustum | The region of physical (3d) space that appears in a view. | |
FrustumPlanes | Represents a the planes of a Frustum for testing containment and intersection. | |
GeocentricTransform | This class represents a geocentric (three parameters) geodetic transformation. | |
GeodeticDatum | This class represents a geodetic datum. | |
GeodeticEllipsoid | This class defines the mathematical model of the Earth shape in the form of an ellipsoid. | |
GeodeticTransform | This class represents a geodetic transformation that enables transforming longitude/latitude coordinates | |
GeodeticTransformPath | This class represents a geodetic datum transform path. | |
GeographicCRS | Geographic Coordinate Reference System implementation. | |
GeometryParams | Describes the display properties of graphics in a persistent element's GeometryStream that aren't inherited from SubCategoryAppearance. | |
GeometryStreamBuilder | GeometryStreamBuilder is a helper class for populating the GeometryStreamProps array needed to create a GeometricElement or GeometryPart. | |
GeometryStreamIterator | GeometryStreamIterator is a helper class for iterating a GeometryStreamProps. | |
GraphicParams | The "cooked" material and symbology for a RenderGraphic. | |
GridFileDefinition | Grid file definition containing name of the file, the format and the direction it should be applied | |
GridFileTransform | This class represents a grid files based geodetic transformation. | |
GroundPlane | A circle drawn at a Z elevation, whose diameter is the the XY diagonal of the project extents, used to represent the ground as a reference point within a spatial view. | |
Helmert2DWithZOffset | An affine transformation with an additional Z Offset. | |
HemisphereLights | Describes a pair of hemisphere lights associated with a LightSettings. | |
HorizontalCRS | Horizontal Geographic Coordinate reference System implementation. | |
HorizontalCRSExtent | The extent in latitude, longitude bounds where a horizontal CRS is applicable | |
HSLColor | An immutable color defined by Hue, Saturation, and Lightness. | |
HSVColor | An immutable color defined by Hue, Saturation, and Value | |
ImageBuffer | Uncompressed rectangular bitmap image data. | |
ImageGraphic | A geometric primitive that displays an image mapped to the corners of a quadrilateral, with an optional border. | |
ImageGraphicCorners | Defines the 4 corners of an ImageGraphic. | |
ImageMapLayerSettings | Normalized representation of a ImageMapLayerProps for which values have been validated and default values have been applied where explicit values not defined. | |
ImageSource | Image data encoded and compressed in either Jpeg or Png format. | |
IModel | Represents an iModel in JavaScript. | |
IModelError | The error type thrown by this module. | |
IModelNotFoundResponse | Response if the IModelDb was not found at the backend | |
IModelTileRpcInterface | ||
IModelVersion | Option to specify the version of the iModel to be acquired and used | |
LightSettings | Describes the lighting for a 3d scene, associated with a DisplayStyle3dSettings in turn associated with a DisplayStyle3d or DisplayStyle3dState. | |
MapImagerySettings | Provides access to the map imagery settings (Base and layers). | |
MapLayerSettings | Abstract base class for normalized representation of a MapLayerProps for which values have been validated and default values have been applied where explicit values not defined. | |
MapSubLayerSettings | Normalized representation of a MapSubLayerProps for which values | |
ModelClipGroup | Describes how to clip a group of models in the context of a ViewDefinition3d by applying a single [ClipVector]($core-geometry] to each model in the group. | |
ModelClipGroups | Describes how to clip groups of models in the context of a ViewDefinition3d or ViewState3d. | |
ModelMapLayerSettings | Normalized representation of a ModelMapLayerProps for which values have been validated and default values have been applied where explicit values not defined. | |
NoContentError | Intended for API "no content" semantics where the error case should not trigger application failure monitoring systems. | |
OctEncodedNormal | Represents a 3d normal vector compressed into a single 16-bit integer using oct-encoding. | |
Placement2d | The placement of a GeometricElement2d. | |
Placement3d | The placement of a GeometricElement3d. | |
PlanarClipMaskSettings | Describes how to mask the geometry of one GeometricModel for display. | |
PlanProjectionSettings | Describes how to draw a plan projection model. | |
PointCloudDisplaySettings | Settings that control how a point cloud reality model is displayed within a Viewport. | Beta |
PositionalVectorTransform | This class represents a positional vector (seven parameters) geodetic transformation corresponding to | |
Projection | This class encapsulates the projection of the CRS. | |
PropertyMetaData | Metadata for a property. | Beta |
PropertyMetaDataMap | Beta | |
QParams2d | Parameters used for QParams2d.Quantization of 2d points such that the x and y components are each quantized to 16-bit unsigned integers. |
|
QParams3d | Parameters used for QParams3d.Quantization of 3d points such that the x , y , and z components are each quantized to 16-bit unsigned integers. |
|
QPoint2d | Represents a Point2d compressed such that each component x and y is quantized to the 16-bit integer range [0, 0xffff]. |
|
QPoint2dBufferBuilder | Constructs a QPoint2dBuffer using a Uint16ArrayBuilder. | |
QPoint2dList | A list of QPoint2ds all quantized to the same range. | |
QPoint3d | Represents a Point3d compressed such that each component x , y , and z is quantized to the 16-bit integer range [0, 0xffff]. |
|
QPoint3dBufferBuilder | Constructs a QPoint3dBuffer using a Uint16ArrayBuilder. | |
QPoint3dList | A list of QPoint3ds all quantized to the same range. | |
QueryBinder | ||
QueryOptionsBuilder | ||
RealityModelDisplaySettings | Settings that control how a reality model - whether a ContextRealityModel or a persistent reality Model - is displayed within a Viewport. | Beta |
RelatedElement | The Id and relationship class of an Element that is somehow related to another Element | |
RenderMaterial | Represents a material which can be applied to a surface to control aspects of its appearance such as color, reflectivity, texture, and so on. | |
RenderTexture | Represents a texture image applied to a surface during rendering. | |
RgbColor | An immutable representation of a color with red, green, and blue components each in the integer range [0, 255]. | |
RpcConfiguration | A RpcConfiguration specifies how calls on an RPC interface will be marshalled, plus other operating parameters. | Beta |
RpcControlResponse | An RPC operation control response. | |
RpcInterface | An RPC interface is a set of operations exposed by a service that a client can call, using configurable protocols, | |
RpcManager | RPC interface management is concerned with coordination of access and configuration for RPC interfaces. | Beta |
RpcNotFoundResponse | A RPC operation response. | |
RpcPendingResponse | A pending RPC operation response. | |
RpcRoutingToken | Beta | |
ServerError | ||
ServerTimeoutError | ||
SkyBox | Describes how to draw a representation of a sky, as part of an Environment. | |
SkyCube | Describes how to draw a representation of a sky by mapping images to the interior faces of a cube. | |
SkyGradient | Describes how to map a two- or four-color SkyGradient.Gradient to the interior of a sphere to produce a SkyBox. | |
SkySphere | Describes how to draw a representation of a sky by mapping a single image to the interior of a sphere. | |
SolarLight | Describes the solar directional light associated with a LightSettings. | |
SolarShadowSettings | Settings controlling display of solar shadows for a DisplayStyle3dSettings. | |
SpatialClassifier | Describes how to use the geometry of one GeometricModel to classify the contents of other models - most typically, reality models. | |
SpatialClassifierFlags | Flags affecting how a SpatialClassifier is applied. | |
SpatialClassifiers | A set of SpatialClassifiers for a given reality model. | |
SubCategoryAppearance | Parameters that define the way geometry on a SubCategory appears. | |
SubCategoryOverride | Overrides selected aspects of a SubCategoryAppearance in the context of a DisplayStyleState. | |
TerrainSettings | Normalized version of TerrainProps for which provider has been validated and default values of all members are used. | |
TextString | A single line of text, all with the same font, styles (underline, bold, italic), and size. | |
TextureMapping | Describes how to map a RenderTexture's image onto a surface as part of a RenderMaterial. | |
ThematicDisplay | The thematic display setup of a DisplayStyle3d. | |
ThematicDisplaySensor | A sensor in world space, used for ThematicDisplayMode.InverseDistanceWeightedSensors. | |
ThematicDisplaySensorSettings | Settings for sensor-based thematic display for ThematicDisplayMode.InverseDistanceWeightedSensors. | |
ThematicGradientSettings | Thematic settings specific to creating a color gradient used by ThematicDisplay. | |
Tween | A Tween for interpolating values of an object. | |
Tweens | A group of Tween s. |
|
TypeDefinition | A RelatedElement relationship that describes the TypeDefinitionElement of an element. | |
Uint8Chunks | Beta | |
VerticalCRS | Vertical Coordinate reference System implementation. | |
ViewDetails | Encapsulates access to optional view details stored in JSON properties. | |
ViewDetails3d | Encapsulates access to optional 3d view details stored in JSON properties. | |
ViewFlags | Flags controlling how graphics appear within a view. | |
WhiteOnWhiteReversalSettings | As part of a DisplayStyleSettings, controls how white-on-white reversal is applied to make white geometry more | |
XyzRotation | Hold 3 components data of a Positional Vector rotation definition in arc seconds |
Constants
Name | Description | |
---|---|---|
ColorByName | A set of known colors by HTML color name, as a 32-bit integer in the form 0xBBGGRR (red is the low byte). | |
Easing | Easing functions from tween.js | |
Interpolation | Interpolation functions from tween.js | |
NpcCenter | The center point of the Normalized Plane Coordinate cube. | |
NpcCorners | The 8 corners of an Npc Frustum. |
Enumerations
Name | Description | |
---|---|---|
BackgroundFill | Describes how a view's background color affects the interior area of a closed region. | |
BackgroundMapType | Enumerates the types of map imagery that can be supplied by a BackgroundMapProvider. | |
BatchType | Describes the type of a 'batch' of graphics representing multiple Features. | |
BentleyStatus | Standard status code. | |
BisCodeSpec | Names of the internal BIS CodeSpecs. | |
BriefcaseIdValue | Values of BriefcaseId that have special meaning. | |
BriefcaseStatus | Error statuses produced by various briefcase operations, typically encountered as the errorNumber of an IModelError. |
|
ChangedValueState | The enum represents the values for the ChangedValueState argument of the ECSQL function Changes. | |
ChangeOpCode | Equivalent of the ECEnumeration OpCode in the ECDbChange ECSchema. | |
ChangeSetStatus | Error statuses produced by various Changeset operations, typically encountered as the errorNumber of an IModelError. |
|
ChangesetType | Value to indicate whether a changeset contains schema changes or not | |
CloudStorageProvider | Beta | |
CommonLoggerCategory | Logger categories used by this package | |
DbResult | Values for return codes from BeSQLite functions. | |
DefaultSupportedTypes | All of the currently supported Reality Data types | Beta |
DomainOptions | Option to control the validation and upgrade of domain schemas in the Db | Beta |
ECSqlSystemProperty | Defines the ECSQL system properties. | |
ECSqlValueType | Describes the different data types an ECSQL value can be of. | |
ElementGeometryOpcode | Specifies the type of an entry in a geometry stream. | |
ExternalSourceAttachmentRole | The role that an attached ExternalSource plays. | Beta |
FeatureOverrideType | Options for overriding element appearance. | |
FillDisplay | Whether a closed region should be drawn for wireframe display with its internal area filled or not. | |
FillFlags | Flags indicating whether and how the interiors of closed planar regions is displayed within a view. | |
FontType | The type of a font. | |
GeoCoordStatus | This enumeration lists all possible status as returned from a coordinate conversion to or from a | |
GeometryClass | Categorizes a piece of geometry within a GeometryStream. | |
GeometryStreamFlags | Flags applied to the entire contents of a GeometryStreamProps. | |
GeometrySummaryVerbosity | Describes the level of detail with which to report each geometric primitive in a GeometrySummaryRequestProps. | |
GlobeMode | Describes the projection of the background map | |
GridOrientationType | Describes the orientation of the grid displayed within a Viewport. | |
HSVConstants | ||
ImageBufferFormat | Format of an ImageBuffer. | |
ImageSourceFormat | The format of an ImageSource. | |
IModelStatus | Status codes that are used in conjunction with BentleyError. | |
InternetConnectivityStatus | Indicates whether or not the computer is currently connected to the internet. | Beta |
LinePixels | Enumerates the available patterns for drawing patterned lines. | |
MassPropertiesOperation | Specify whether to accumulate volumes, areas, or lengths for the supplied elements. | |
MonochromeMode | Describes the style in which monochrome color is applied by a DisplayStyleSettings. | |
NormalMapFlags | Flags applied to a NormalMapProps. | |
Npc | The 8 corners of the Normalized Plane Coordinate cube. | |
OverriddenBy | Describes whether the user or the browser overrode the internet connectivity status. | Beta |
PlanarClipMaskMode | The different modes by which a PlanarClipMaskSettings collects the geometry used to mask a model. | |
PlanarClipMaskPriority | The default priority values for a PlanarClipMaskSettings, based on model type. | |
PrimitiveTypeCode | The primitive types of an Entity property. | Beta |
ProfileOptions | Options that control whether a profile upgrade should be performed when opening a Db | Beta |
QueryRowFormat | Specifies the format of the rows returned by the query and restartQuery methods of |
|
Rank | The rank for a Category | |
RealityDataFormat | Identify the Reality Data storage format | Beta |
RealityDataProvider | Identify the Reality Data service provider | Beta |
RenderMode | Enumerates the available basic rendering modes, as part of a DisplayStyle's ViewFlags. | |
RpcContentType | RPC content types. | Deprecated |
RpcEndpoint | Endpoints for RPC protocols. | Deprecated |
RpcProtocolEvent | RPC protocol event types. | Deprecated |
RpcRequestEvent | RPC request event types. | Deprecated |
RpcRequestStatus | The status of an RPC operation request. | Deprecated |
RpcResponseCacheControl | Describes available options for RPC response caching. | |
SchemaState | The state of the schemas in the Db compared with what the current version of the software expects | Beta |
SectionType | An enumeration of the different types of SectionDrawings. | |
SkyBoxImageType | Supported types of SkyBox images. | |
SpatialClassifierInsideDisplay | Describes how a SpatialClassifier affects the display of classified geometry - that is, geometry intersecting | |
SpatialClassifierOutsideDisplay | Describes how a SpatialClassifier affects the display of unclassified geometry - that is, geometry not intersecting | |
SyncMode | Whether a briefcase is editable or may only accept incoming changesets from iModelHub | |
TerrainHeightOriginMode | Correction modes for terrain height | |
TextureMapUnits | Describes the units in which a TextureMapProps' scale is expressed. | |
TextureTransparency | Describes the type of transparency in the pixels of a TextureImage. | |
ThematicDisplayMode | The thematic display mode. | |
ThematicGradientColorScheme | A color scheme used to generate the colors of a thematic gradient within an applied range. | |
ThematicGradientMode | A thematic gradient mode used to generate and apply a thematic effect to a scene. | |
TxnAction | Describes the types of actions associated with Txns. | |
TypeOfChange | Bitflags describing which aspects of an Element changed as part of a ChangedElements. |
Global Functions
Name | Description | |
---|---|---|
calculateSolarAngles | ||
calculateSolarDirection | ||
calculateSolarDirectionFromAngles | ||
calculateSunriseOrSunset | ||
isPlacement2dProps | determine if this is Placement2dProps | |
isPlacement3dProps | determine if this is Placement3dProps | |
isPowerOfTwo | Returns whether the input is a power of two. | |
mapToGeoServiceStatus | Maps a GeoCoordStatus to the equivalent GeoServiceStatus. | |
nextHighestPowerOfTwo | Returns the first power-of-two value greater than or equal to the input. | |
readElementMeshes | Convert the output of IModelConnection.generateElementMeshes into an array of Polyfaces. | Beta |
Interfaces
Name | Description | |
---|---|---|
AdditionalTransformProps | Additional Transform definition | |
AffineTransformProps | The equations are: | |
AmbientLightProps | Wire format for the ambient light associated with a LightSettingsProps. | |
AnalysisStyleDisplacementProps | JSON representation of an AnalysisStyleDisplacement. | |
AnalysisStyleProps | JSON representation of an AnalysisStyle. | |
AnalysisStyleThematicProps | JSON representation of an AnalysisStyleThematic. | |
AppearanceOverrideProps | JSON representation of an appearance override in an EmphasizeElementsProps. | |
AreaFillProps | Add a AreaFillProps.gradient, AreaFillProps.backgroundFill, or solid AreaFillProps.color fill to subsequent planar regions (or meshes). | |
AuthorizationClient | Provides authorization to access APIs. | |
AuxCoordSystem2dProps | Properties of AuxCoordSystem2d | |
AuxCoordSystem3dProps | Properties of AuxCoordSystem3d | |
AuxCoordSystemProps | ||
BackgroundMapProps | In-memory JSON representation of a BackgroundMapSettings. | |
BackgroundMapProviderProps | JSON representation of a BackgroundMapProvider. | |
BaseMapLayerProps | JSON representation of a BaseMapLayerSettings. | |
BaseReaderOptions | Config for all request made to concurrent query engine. | |
BasicPlanarClipMaskArgs | Basic arguments supplied to PlanarClipMaskSettings.create. | |
BentleyCloudRpcParams | Initialization parameters for BentleyCloudRpcConfiguration. | Beta |
BlobOptions | Beta | |
BRepPrimitive | Represents a BRep within a GeometryStream. | |
BriefcaseDownloader | Manages the download of a briefcase | |
BriefcaseProps | Properties that specify a briefcase within the local briefcase cache. | |
CalloutProps | ||
CameraProps | JSON representation of a Camera. | |
Carto2DDegreesProps | A 2D cartographic point in degrees | |
CartographicProps | The JSON representation of a Cartographic object. | |
CategoryProps | Parameters of a Category | |
CategorySelectorProps | Properties that define a CategorySelector | |
ChangedElements | Changed elements found in a changeset or between a range of changesets. | |
ChangedEntities | JSON representation of the set of Elements or Models that were changed by a Txn. | |
ChangesetFileProps | Properties of a changeset file | Beta |
ChangesetIdWithIndex | The Id and optionally the index of a changeset | |
ChangesetIndexAndId | Both the index and Id of a changeset | |
ChangesetProps | Properties of a changeset | Beta |
ChangesetRange | A range of changesets | |
ChannelRootAspectProps | Properties of an ChannelRootAspect that identifies an Element as the root of a channel which is a subset of the overall iModel hierarchy that is independently maintained. | |
ClipStyleProps | Wire format describing a ClipStyle. | |
CloudContainerUri | Beta | |
CloudStorageContainerDescriptor | Beta | |
CloudStorageContainerUrl | Beta | |
CodeProps | The wire format for a Code | |
CodeSpecProperties | The JSON properties of a CodeSpec | |
CommonMapLayerProps | JSON representation of properties common to both ImageMapLayerProps and ModelMapLayerProps. | |
ContextRealityModelProps | JSON representation of a ContextRealityModel. | |
ContextRealityModelsArgs | Arguments supplied to the constructor of ContextRealityModels. | |
ContextRealityModelsContainer | An object that can store the JSON representation of a list of ContextRealityModels. | |
CreateIModelProps | The properties that can be supplied when creating a new iModel. | |
CreateSnapshotIModelProps | Options that can be supplied when creating snapshot iModels. | |
CustomAttribute | A custom attribute instance | Beta |
CutStyleProps | Wire format describing a CutStyle applied to section-cut geometry produced at intersections with a view's ClipVector. | |
DbRuntimeStats | Beta | |
DefinitionElementProps | Properties of a DefinitionElement | |
DeletedElementGeometryChange | Represents the deletion of a GeometricElement. | |
DeprecatedBackgroundMapProps | Properties of PersistentBackgroundMapProps that have been deprecated, but are retained for backwards compatibility. | |
DisplayStyle3dProps | JSON representation of a DisplayStyle3d or DisplayStyle3dState. | |
DisplayStyle3dSettingsProps | JSON representation of DisplayStyle3dSettings associated with a DisplayStyle3dProps. | |
DisplayStyleLoadProps | Options controlling which properties are included or excluded when querying DisplayStyleProps. | |
DisplayStyleModelAppearanceProps | A FeatureAppearanceProps applied to a specific model to override its appearance within the context of a DisplayStyle. | |
DisplayStyleOverridesOptions | Controls which settings are serialized by DisplayStyleSettings.toOverrides. | |
DisplayStylePlanarClipMaskProps | A PlanarClipMaskProps associated with a specific reality model. | |
DisplayStyleProps | JSON representation of a DisplayStyle or DisplayStyleState. | |
DisplayStyleRealityModelDisplayProps | RealityModelDisplaySettings applied to a reality Model to change how it is rendered within the context of a DisplayStyle. | Beta |
DisplayStyleSettingsOptions | Options supplied when constructing a DisplayStyleSettings. | |
DisplayStyleSettingsProps | JSON representation of the DisplayStyleSettings associated with a DisplayStyleProps. | |
DisplayStyleSubCategoryProps | Describes the SubCategoryOverrides applied to a SubCategory by a DisplayStyle. | |
DynamicGraphicsRequest2dProps | Wire format describing a request to produce graphics in "iMdl" format for a 2d geometry stream. | |
DynamicGraphicsRequest3dProps | Wire format describing a request to produce graphics in "iMdl" format for a 3d geometry stream. | |
DynamicGraphicsRequestProps | Wire format describing a request to produce graphics in "iMdl" format for a single geometry stream. | |
EcefLocationProps | Properties that position an iModel on the earth via ECEF (Earth Centered Earth Fixed) coordinates | |
ECSchemaItemProps | ||
ECSchemaProps | Properties of an ECSchema | |
ECSchemaReferenceProps | ||
ElementAspectProps | Properties of an ElementAspect | |
ElementGeometryDataEntry | Describes an entry in a geometry stream as an op-code plus the binary flatbuffer representation of the associated data. | |
ElementIdsAndRangesProps | Compact wire format representing geometric changes to a set of elements as part of a ModelGeometryChangesProps. | |
ElementLoadOptions | Options used to specify properties to include or exclude when querying ElementProps with functions like | |
ElementLoadProps | Parameters to specify what element to load for functions like IModelDb.Elements.getElementProps. | |
ElementMeshOptions | Options used to control how Polyfaces are produced from elements by IModelConnection.generateElementMeshes. | Beta |
ElementMeshRequestProps | Describes a request to generate Polyfaces from an element. | Beta |
ElementPlanarClipMaskArgs | Arguments supplied to PlanarClipMaskSettings.create to create a mask of PlanarClipMaskMode.IncludeElements or PlanarClipMaskMode.ExcludeElements. | |
ElementProps | Properties of an Element | |
EmphasizeElementsProps | JSON representation of an EmphasizeElements. | |
EntityIdAndClassId | Describes an Entity and its ECClass by Id. | |
EntityMetaDataProps | Beta | |
EntityProps | The persistent format of an Entity, also used as the "wire format" when transmitting information about entities | |
EntityQueryParams | Parameters for performing a query on Entity classes. | |
EnvironmentProps | JSON representation of an Environment. | |
ExtantElementGeometryChange | Represents the insertion of a new GeometricElement, or a change to the geometric properties of an existing GeometricElement. | |
ExternalSourceAspectProps | Properties of an ExternalSourceAspect that stores synchronization information for an element originating from an external source. | |
ExternalSourceAttachmentProps | Properties of an ExternalSourceAttachment | Beta |
ExternalSourceProps | Properties of an ExternalSource | Beta |
FeatureAppearanceProps | JSON representation of a FeatureAppearance. | |
FeatureAppearanceProvider | Interface adopted by an object that can supply the FeatureAppearance supplied by a FeatureAppearanceSource. | |
FeatureAppearanceSource | Interface adopted by an object that can supply a FeatureAppearance given a low-level description of a Feature. | |
FilePropertyProps | ||
FlatBufferGeometryStream | As part of a DynamicGraphicsRequestProps, specifies the geometry from which to generate the graphics in binary flatbuffer-encoded format. | |
FontMapProps | The properties of a FontMap | |
FontProps | The properties of a Font. | |
FresnelSettingsProps | JSON representation of a FresnelSettings. | |
FunctionalElementProps | ||
GeocentricTransformProps | This interface represents a geocentric (three parameters) geodetic transformation. | |
GeoCoordinatesRequestProps | Information required to request conversion of an array of iModel coordinates to Geographic Coordinates (longitude and latitude) | Beta |
GeoCoordinatesResponseProps | Information returned from a request to convert an array of iModel coordinates to Geographic Coordinates (longitude and latitude) | Beta |
GeodeticDatumProps | This interface represents a geodetic datum. | |
GeodeticEllipsoidProps | This interface defines the mathematical model of the Earth shape in the form of an ellipsoid. | |
GeodeticTransformPathProps | This interface represents a geodetic datum transform path. | |
GeodeticTransformProps | This interface represents a geodetic transformation that enables transforming longitude/latitude coordinates | |
GeographicCRSInterpretRequestProps | Information required to interpret or complete a Geographic CRS in the specified format. | Beta |
GeographicCRSInterpretResponseProps | Information returned from a request to interpret or complete a Geographic CRS | Beta |
GeographicCRSProps | Geographic Coordinate Reference System definition that includes the horizontal and vertical definitions as well as an optional | |
GeometricElement2dProps | Properties that define a GeometricElement2d | |
GeometricElement3dProps | Properties that define a GeometricElement3d | |
GeometricElementProps | Properties of a GeometricElement | |
GeometricModel2dProps | Properties that define a GeometricModel2d | |
GeometricModel3dProps | Properties that define a GeometricModel3d | |
GeometricModelProps | Properties that describe a GeometricModel | |
GeometryAppearanceProps | Establish a non-default SubCategory or to override SubCategoryAppearance for the geometry that follows. | |
GeometryContainmentRequestProps | Information required to request clip containment status for elements from the front end to the back end. | |
GeometryContainmentResponseProps | Information returned from the back end to the front end holding the result of the geometry containment query. | |
GeometryPartInstanceProps | Add a reference to a GeometryPart from the GeometryStream of a GeometricElement. | |
GeometryPartProps | Properties of a GeometryPart | |
GeometryPrimitive | Represents one of a variety of GeometryQuery objects within a GeometryStream. | |
GeometryStreamEntryProps | Allowed GeometryStream entries - should only set one value. | |
GeometryStreamHeaderProps | An entry in a GeometryStreamProps containing GeometryStreamFlags that apply to the geometry stream as a whole. | |
GeometryStreamIteratorEntry | Holds current state information for GeometryStreamIterator. | |
GeometrySummaryOptions | Describes what information to include in a GeometrySummaryRequestProps. | |
GeometrySummaryRequestProps | Describes the elements for which to generate an array of geometry summaries and the options controlling the contents of each summary. | |
GraphicsRequestProps | Wire format describing properties common to PersistentGraphicsRequestProps and DynamicGraphicsRequestProps. | |
GridFileDefinitionProps | Grid file definition containing name of the file, the format and the direction it should be applied | |
GridFileTransformProps | This interface represents a grid files based geodetic transformation. | |
GroundPlaneProps | JSON representation of a GroundPlane. | |
Helmert2DWithZOffsetProps | An affine transformation with an additional Z Offset. | |
HemisphereLightsProps | Wire format for a pair of hemisphere lights associated with a LightSettingsProps. | |
HorizontalCRSExtentProps | The extent in latitude, longitude bounds where a horizontal CRS is applicable | |
HorizontalCRSProps | Horizontal Geographic Coordinate Reference System definition | |
HttpServerRequest | An HTTP server request object. | Deprecated |
HttpServerResponse | An HTTP server response object. | Deprecated |
IgnoreAnimationOverridesArgs | Arguments provided to a function of type IgnoreAnimationOverrides. | |
ImageGraphicProps | JSON representation of an ImageGraphic. | |
ImageMapLayerProps | JSON representation of an ImageMapLayerSettings. | |
ImagePrimitive | Represents an image within a GeometryStream. | |
IModelCoordinatesRequestProps | Information required to request conversion of an array of Geographic coordinates (Longitude/Latitude) to iModel coordinates | Beta |
IModelCoordinatesResponseProps | Beta | |
IModelEncryptionProps | Encryption-related properties that can be supplied when creating or opening snapshot iModels. | Deprecated |
IModelProps | Properties of an iModel that are always held in memory whenever one is opened, both on the frontend and on the backend . | |
IModelRpcOpenProps | The properties to open a connection to an iModel for RPC operations. | |
IModelRpcProps | The properties that identify an opened iModel for RPC operations. | |
InformationPartitionElementProps | Properties of a InformationPartitionElement | |
IpcSocket | An inter-process socket connection between a single IModelHost on the backend (the node process), and an IModelApp on | |
IpcSocketBackend | Interface for the backend (Node.js) side of a socket connection. | |
IpcSocketFrontend | Interface for the frontend (browser) side of a socket connection. | |
JsonGeometryStream | As part of a DynamicGraphicsRequestProps, specifies the geometry from which to generate the graphics in JSON format. | |
LightSettingsProps | Wire format for a LightSettings describing lighting for a 3d scene. | |
LineStyleProps | Properties of a LineStyle | |
LocalBriefcaseProps | Properties of a local briefcase file, returned by BriefcaseManager.getCachedBriefcases and BriefcaseManager.downloadBriefcase | |
Localization | The interface defining the localization requirements of IModelApp. | |
MapImageryProps | The JSON representation of the map imagery. | |
MapLayerKey | stores key-value pair to be added to all requests made involving map layer. | |
MapSubLayerProps | JSON representation of the settings associated with a map sublayer included within a MapLayerProps. | |
MassPropertiesPerCandidateRequestProps | Information required to request mass properties for each element separately from the front end to the back end. | |
MassPropertiesPerCandidateResponseProps | Information returned from the back end to the front end holding the result of the mass properties calculation for a single candidate. | |
MassPropertiesRequestProps | Information required to request mass properties for elements from the front end to the back end. | |
MassPropertiesResponseProps | Information returned from the back end to the front end holding the result of the mass properties calculation. | |
MaterialProps | Override SubCategoryAppearance.materialId for subsequent surface and solid geometry. | |
ModelClipGroupProps | JSON representation of a ModelClipGroup. | |
ModelExtentsProps | Describes the volume of geometry contained with a GeometricModel as returned by | |
ModelGeometryChanges | Represents geometric changes to a set of GeometricElements belonging to a single GeometricModel. | |
ModelGeometryChangesProps | Compact wire format representing geometric changes to GeometricElements within a GeometricModel. | |
ModelIdAndGeometryGuid | Specifies a GeometricModel's Id and a Guid identifying the current state of the geometry contained within the model. | |
ModelLoadProps | Properties that specify what model should be loaded. | |
ModelMapLayerProps | JSON representation of a ModelMapLayerSettings. | |
ModelPlanarClipMaskArgs | Arguments supplied to PlanarClipMaskSettings.create to create a mask of PlanarClipMaskMode.Models. | |
ModelProps | Properties that define a Model | |
ModelQueryParams | Parameters for performing a query on Model classes. | |
ModelSelectorProps | Properties that define a ModelSelector | |
NavigationBindingValue | An ECSQL Navigation value which can be bound to a navigation property ECSQL parameter | |
NavigationValue | An ECSQL Navigation value. | |
NormalMapParams | Defines normal map parameters. | Beta |
NormalMapProps | Describes how to apply normal mapping to a surface material. | |
OpenAPIInfo | An OpenAPI 3.0 info object. | Deprecated |
OpenBriefcaseOptions | Options to open a previously downloaded briefcase | |
OpenBriefcaseProps | Properties for opening a local briefcase file via BriefcaseDb.open | |
OpenDbKey | A key used to identify an opened IModelDb between the frontend and backend for Rpc and Ipc communications. | |
OverrideElementAppearanceOptions | Options for using FeatureOverrides.override to override the appearance of a GeometricElement. | |
OverrideFeatureAppearanceOptions | Common options for FeatureOverrides.override. | |
OverrideModelAppearanceOptions | Options for using FeatureOverrides.override to override the appearance of a GeometricModel. | |
OverrideSubCategoryAppearanceOptions | Options for using FeatureOverrides.override to override the appearance of a SubCategory. | |
PartReference | Represents a reference to a GeometryPart within a GeometryStream. | |
PersistentGraphicsRequestProps | Wire format describing a request to produce graphics in "iMdl" format for a single element. | |
PhysicalElementProps | Properties that define a PhysicalElement | |
PhysicalTypeProps | Properties of a PhysicalType | |
Placement2dProps | Properties of a Placement2d | |
Placement3dProps | Properties of a Placement3d | |
PlanarClipMaskProps | JSON representation of a PlanarClipMaskSettings. | |
PlanProjectionSettingsProps | Wire format describing PlanProjectionSettings. | |
PointCloudDisplayProps | The JSON representation of PointCloudDisplaySettings. | Beta |
PointWithStatus | Information returned from a request to convert an array of Geographic coordinates (Longitude/Latitude) to iModel coordinates | Beta |
PositionalVectorTransformProps | This interface represents a positional vector (seven parameters) geodetic transformation corresponding to | |
PriorityPlanarClipMaskArgs | Arguments supplied to PlanarClipMaskSettings.create to create a mask of PlanarClipMaskMode.Priority. | |
ProjectionProps | This class encapsulates the projection of the CRS. | |
PropertyMetaDataProps | Beta | |
QPoint2dBuffer | A compact representation of a list of QPoint2ds stored in a Uint16Array |
|
QPoint3dBuffer | A compact representation of a list of QPoint3ds stored in a Uint16Array . |
|
QueryLimit | Specify limit or range of rows to return | |
QueryOptions | ECSql query config | |
QueryPropertyMetaData | Beta | |
QueryQuota | Quota hint for the query. | |
QueryRowProxy | Beta | |
QueryStats | Beta | |
RealityData | RealityData | Beta |
RealityDataAccess | Client wrapper to Reality Data Service. | Beta |
RealityDataSourceKey | Key used by RealityDataSource to identify provider and reality data format | Beta |
RealityDataSourceProps | JSON representation of the reality data reference attachment properties. | Beta |
RealityModelDisplayProps | The JSON representation of RealityModelDisplaySettings. | Beta |
RelatedElementProps | Properties of a NavigationProperty. | |
RelationshipProps | Properties that are common to all types of link table ECRelationships | |
RenderMaterialAssetMapsProps | Describes different types of textures to be applied to a surface material to alter its appearance. | |
RenderMaterialAssetProps | Describes the graphical properties of a RenderMaterialElement as part of a RenderMaterialProps. | |
RenderMaterialProps | Properties that define a RenderMaterialElement. | |
RenderTimelineLoadProps | Options controlling which properties are included or excluded when querying RenderTimelineProps. | |
RenderTimelineProps | Wire format describing a RenderTimeline. | |
RepositoryLinkProps | Parameters of a RepositoryLink | |
RequestNewBriefcaseProps | Properties for downloading a briefcase to a local file, from iModelHub. | |
RgbColorProps | JSON representation of an RgbColor, with each component an integer in the range [0, 255]. | |
RootSubjectProps | Properties of the Root Subject. | |
RpcActivity | The properties of an RpcActivity. | |
RpcInterfaceDefinition | Specifies the required static properties of an RpcInterface class. | Beta |
RpcInterfaceEndpoints | Describes the endpoints of an RPC interface. | Beta |
SectionDrawingLocationProps | Properties that define a SectionDrawingLocation | |
SectionDrawingProps | Properties that define a SectionDrawing. | |
SectionDrawingViewProps | As part of a ViewStateProps, describes the SpatialViewDefinition from which a SectionDrawing was generated. | |
SerializedRpcActivity | Serialized format for sending the request across the RPC layer | |
SessionProps | Properties that identify a session. | |
SheetBorderTemplateProps | Properties of a SheetBorderTemplate | Beta |
SheetProps | Properties of a Sheet. | |
SheetTemplateProps | Properties of a SheetTemplate | Beta |
SkyBoxProps | JSON representation of a SkyBox that can be drawn as the background of a ViewState3d. | |
SkyCubeImageProps | JSON representation of the images used for a SkyCube. | |
SkyCubeProps | JSON representation of the six images used by a SkyCube. | |
SkySphereImageProps | JSON representation of the image used for a SkySphere. | |
SnapshotOpenOptions | Options to open a SnapshotDb. | |
SolarLightProps | Wire format for the solar directional light associated with a LightSettingsProps. | |
SolarShadowSettingsProps | JSON representation of SolarShadowSettings. | |
SourceAndTarget | Specifies the source and target elements of a SourceAndTarget.Relationship instance. | |
SpatialClassifierFlagsProps | JSON representation of a SpatialClassifierFlags. | |
SpatialClassifierProps | JSON representation of a SpatialClassifier. | |
SpatialClassifiersContainer | An object that can store the JSON representation of a list of SpatialClassifiers. | |
SpatialViewDefinitionProps | Parameters to construct a SpatialViewDefinition | |
SubCategoryPlanarClipMaskArgs | Arguments supplied to PlanarClipMaskSettings.create to create a mask of PlanarClipMaskMode.IncludeSubCategories. | |
SubCategoryProps | Parameters of a SubCategory | |
SubjectProps | Properties of a Subject | |
SynchronizationConfigLinkProps | The properties of a SynchronizationConfigLink | Beta |
TerrainProps | JSON representation of the settings of the terrain applied to background map display by a DisplayStyle. | |
TextStringPrimitive | Represents a text string within a GeometryStream. | |
TextStringProps | Properties for a TextString class. | |
TextureData | Information about Texture data returned by IModelReadRpcInterface.queryTextureData. | |
TextureLoadProps | Properties that specify what texture should be loaded and how it should be loaded. | |
TextureMapProps | As part of a RenderMaterialAssetProps, describes how to map a RenderTexture's image to the triangles of a mesh to which the material is applied. | |
TextureProps | Properties that define a Texture element. | |
ThematicDisplayProps | JSON representation of the thematic display setup of a DisplayStyle3d. | |
ThematicDisplaySensorProps | JSON representation of a ThematicDisplaySensor. | |
ThematicDisplaySensorSettingsProps | JSON representation of a ThematicDisplaySensorSettings for ThematicDisplayMode.InverseDistanceWeightedSensors. | |
ThematicGradientSettingsProps | JSON representation of a ThematicGradientSettings. | |
ThumbnailFormatProps | Metadata about a thumbnail image. | |
ThumbnailProps | Describes a thumbnail image for an IModel or ViewDefinition. | |
TileContentIdentifier | Beta | |
TileVersionInfo | Metadata describing the version/format of the tiles supplied by the backend. | |
TranslationOptions | Options for Localization | |
TypeDefinitionElementProps | Properties of a TypeDefinitionElement | |
UpgradeOptions | Arguments to validate and update the profile and domain schemas when opening a Db | Beta |
UrlLinkProps | Parameters of a UrlLink | |
VerticalCRSProps | Vertical Geographic Coordinate reference System definition | |
ViewAttachmentLabelProps | ||
ViewAttachmentProps | Properties for a ViewAttachment | |
ViewDefinition2dProps | Parameters used to construct a ViewDefinition2d | |
ViewDefinition3dProps | Parameters to construct a ViewDefinition3d | |
ViewDefinitionProps | Parameters used to construct a ViewDefinition | |
ViewDetails3dProps | Properties of a ViewDefinition3dProps stored as JSON. | |
ViewDetailsProps | Properties of a ViewDefinitionProps stored as JSON. | |
ViewFlagProps | JSON representation of ViewFlags. | |
ViewQueryParams | Parameters for performing a query on ViewDefinition classes. | |
ViewStateLoadProps | Options for loading a ViewStateProps via IModelConnection.Views.load or IModelDb.Views.getViewStateData. | |
ViewStateProps | Returned from IModelDb.Views.getViewStateData. | |
WhiteOnWhiteReversalProps | JSON representation of a WhiteOnWhiteReversalSettings. | |
XyzRotationProps | Holds 3 components of a Positional Vector rotation definition in arc seconds |
Namespaces
Name | Description | |
---|---|---|
AmbientOcclusion | Namespace containing types controlling how ambient occlusion should be drawn. | |
AreaPattern | ||
Base64EncodedString | Represents an array of bytes encoded in base-64 with a prefix indicating the encoding, as persisted in an ECDb for properties of binary type. |
|
BaseLayerSettings | ||
BRepEntity | JSON representation of a brep GeometryStream entry. | |
CloudStorageContainerUrl | Beta | |
CodeScopeSpec | The scope of the Code. | |
ContextRealityModelProps | ||
ElementGeometryChange | Represents a change to the geometry of a GeometricElement, as exposed by ModelGeometryChanges.elements. | |
FeatureAppearanceProvider | ||
FrustumPlanes | ||
Gradient | Namespace containing types for defining a color gradient, often used for filled planar regions. | |
HiddenLine | Namespace containing types controlling how edges and surfaces should be drawn in "hidden line" and "solid fill" RenderModes. | |
Hilite | Contains types related to display of hilited elements within a Viewport. | |
LineStyle | ||
ModelGeometryChanges | Represents geometric changes to a set of GeometricElements belonging to a single GeometricModel. | |
QPoint2dBuffer | ||
QPoint3dBuffer | ||
Quantization | Provides facilities for quantizing floating point values within a specified range into 16-bit unsigned integers. | |
RealityDataFormat | Utility function for RealityDataFormat | Beta |
RealityDataSourceKey | RealityDataSourceKey utility functions | Beta |
RenderMaterial | ||
RenderSchedule | Namespace containing types that collectively define a script that animates the contents of a view by adjusting the visibility, position, | |
RenderTexture | ||
RpcRequestStatus | ||
SubCategoryAppearance | ||
TextureMapping |
Type Aliases
Name | Description | |
---|---|---|
AxisAlignedBox3d | A Range3d that is aligned with the axes of spatial coordinates. | |
AxisAlignedBox3dProps | The properties of a Range3d. | |
BackendReadable | ||
BackendWritable | ||
BackgroundMapProviderName | Enumerates a set of supported BackgroundMapProviders that can provide map imagery. | |
Base64EncodedString | Represents an array of bytes encoded in base-64 with a prefix indicating the encoding, as required when converting EC properties of binary type to and from JSON. |
|
BaseLayerProps | JSON representation of a BaseLayerSettings. | |
BaseLayerSettings | The base layer for a MapImagerySettings. | |
BlobRange | Beta | |
BriefcaseId | The Id assigned to a briefcase by iModelHub, or BriefcaseIdValue.Unassigned . | |
ChangesetId | A string that identifies a changeset. | |
ChangesetIndex | The index of a changeset, assigned by iModelHub. | |
ChangesetIndexOrId | either changeset index, id, or both | |
CodeScopeProps | The identity of the element defining the scope for a Code value. | |
ColorDefProps | The JSON representation of a ColorDef - an unsigned 32-bit integer in 0xTTBBGGRR format. | |
CreateEmptySnapshotIModelProps | The options that can be specified when creating an empty snapshot iModel. | |
DanishSystem34Region | The type to define the three zones of the Danish System 34 projections. | |
EasingFunction | ||
ElementAlignedBox2d | A bounding box aligned to the orientation of a 2d Element | |
ElementAlignedBox3d | A bounding box aligned to the orientation of a 3d Element | |
ElementGeometryChange | ||
ElementGraphicsRequestProps | Wire format describing a request to produce graphics in "iMdl" format for a single element or geometry stream. | |
EntityIdAndClassIdIterable | A collection of EntityIdAndClassIds, as used by TxnChangedEntities. | |
EnvironmentProperties | A type containing all of the properties of Environment with none of the methods and with the readonly modifiers removed. |
|
FontId | An iModel-local identifier for a font. | |
GeodeticTransformMethod | Type indicating the geodetic transformation method | |
GeometryStreamPrimitive | Union of all possible geometric primitive types that may appear within a GeometryStream. | |
GeometryStreamProps | A GeometricElement's GeometryStream is represented by an array of GeometryStreamEntryProps. | |
GetMetaDataFunction | ||
GridFileDirection | type to indicate the grid file application direction. | |
GridFileFormat | Type indicating the file format of the grid files. | |
GroundPlaneProperties | A type containing all of the properties and none of the methods of GroundPlane, with readonly modifiers removed. |
|
HemisphereEnum | Type used in the definition of UTM Zoning projection. | |
IgnoreAnimationOverrides | ||
ImageGraphicCornersProps | JSON representation of the 4 corners of an ImageGraphicProps. | |
ImageryMapLayerFormatId | The current set of supported map layer formats. | |
IModelConnectionProps | The properties returned by the backend when creating a new IModelConnection from the frontend, either with Rpc or with Ipc. | |
IModelErrorNumber | Numeric values for common errors produced by iTwin.js APIs, typically provided by IModelError. | |
IModelVersionProps | Properties for IModelVersion | |
InterpolationFunction | ||
IpcListener | ||
LocalAlignedBox3d | A bounding box aligned to a local coordinate system | |
LocalDirName | ||
LocalFileName | ||
LogFunction | ||
MapLayerProps | JSON representation of a MapLayerSettings. | |
OverrideFeatureAppearanceArgs | Arguments supplied to FeatureOverrides.override. | |
PersistentBackgroundMapProps | Persistent JSON representation of a BackgroundMapSettings. | |
Placement | Either a Placement2d or Placement3d | |
PlacementProps | ||
Point2dProps | A 2d point specified as an array of 2 numbers [x, y]. | |
PointCloudEDLMode | Specifies the Eye-Dome Lighting mode used for a point cloud. | Beta |
PointCloudShape | Specifies the shape drawn for each individual point within a point cloud. | Beta |
PointCloudSizeMode | Specifies how the sizes of the individual points within a point cloud are computed. | Beta |
ProjectionMethod | This enum contains the list of all projection methods that can be represented as part of the HorizontalCRS | |
PropertyCallback | ||
QueryValueType | Beta | |
RemoveFunction | ||
RgbFactorProps | Describes a color as an array of three numbers ranging from 0 to 1 where the first entry corresponds to the color's red component, | |
RpcInterfaceImplementation | ||
SkyBoxImageProps | JSON representation of the image(s) to be mapped to the surfaces of a SkyBox. | |
SkyGradientProperties | A type containing all of the properties and none of the methods of SkyGradient with readonly modifiers removed. |
|
StandaloneOpenOptions | Options to open a StandaloneDb via StandaloneDb.openFile from the backend, | |
StorageValue | Type of value for storage values | Beta |
SubLayerId | ||
TerrainProviderName | Identifies a TerrainProvider. | Deprecated |
TextureImageSpec | Identifies an image to be used to produce a RenderTexture for a given purpose - for example, | |
TweenCallback | ||
UnitType | This type indicates possible linear and angular units supported. | |
UpdateCallback | ||
ViewFlagOverrides | A type that describes how to override selected properties of a ViewFlags. | |
ViewFlagsProperties | A type containing all of the properties of ViewFlags with none of the methods and with the readonly modifiers removed. |
Last Updated: 20 June, 2023