BriefcaseDownloader Interface
Manages the download of a briefcase
Methods
Name | Description | |
---|---|---|
requestCancel(): Promise<boolean> Readonly | Request cancellation of the download |
Properties
Name | Type | Description | |
---|---|---|---|
briefcaseId Readonly | number | Id of the briefcase being downloaded | |
downloadPromise Readonly | Promise<void> | Promise that resolves when the download completes. | |
fileName Readonly | string | the name of the local file for the briefcase |
Defined in
- core/common/src/BriefcaseTypes.ts Line 157
Last Updated: 20 June, 2023