core-frontend Change Log
The core-frontend package always runs in a web browser. It contains classes for querying iModels and showing views.
Topics
Name | Description |
---|---|
IModelApp | Classes for configuring and administering an iTwin.js application. |
IModelConnection | Classes for working with a connection to an iModel briefcase |
ElementState | Classes for working with the state of Elements in the frontend. |
ModelState | Classes for working with the state of Models in the frontend. |
Tools | Classes for working with Tools |
Measure | Classes for reporting point to point distances and mass properties of elements. |
Views | Classes for working with Views |
LocatingElements | Classes for locating and snapping to elements in views. |
AccuDraw | AccuDraw provides helpful assistance for creating and modifying elements in a view. |
Notifications | Notifications provide feedback to the user of something of interest. |
Properties | Classes for working with property records and descriptions. |
Rendering | Classes for rendering the contents of views. |
SelectionSet | Classes for working with the set of selected elements. |
NativeApp | Classes for working with Native Applications |
Logging | Logger categories used by this package |
QuantityFormatting | Classes for formatting and parsing quantity values. |
Tiles | Classes representing graphics as hierarchical 3d tiles. |
HubAccess | APIs for working with IModelHub |
UserPreferences | APIs for working with user preferences in an iModelApp. |
MapLayers | Classes supporting map layers display. |
TileStorage | Class for working with cloud storage using iTwin/object-storage cloud providers |
All | Displays the contents of all topics in this package. |
Last Updated: 20 June, 2023