ThematicGradientSettings Class
Thematic settings specific to creating a color gradient used by ThematicDisplay.
Methods
Name | Description | |
---|---|---|
clone(changedProps?: ThematicGradientSettingsProps): ThematicGradientSettings | Create a copy of this ThematicGradientSettings, optionally modifying some of its properties. | |
equals(other: ThematicGradientSettings): boolean | ||
toJSON(): ThematicGradientSettingsProps | ||
compare(lhs: ThematicGradientSettings, rhs: ThematicGradientSettings): number Static | Compares two sets of thematic gradient settings. | |
fromJSON(json?: ThematicGradientSettingsProps): ThematicGradientSettings Static |
Properties
Name | Type | Description | |
---|---|---|---|
colorMix Readonly | number | The percentage to mix in the original color with the thematic display gradient color (0-1). | |
colorScheme Readonly | ThematicGradientColorScheme | The color scheme used to generate the colors of the gradient color within the applied range. | |
contentMax Accessor StaticReadOnly | number | ||
contentRange Accessor StaticReadOnly | number | ||
customKeys Readonly | Gradient.KeyColor[] | The key color values that must be provided when using a custom thematic color scheme. | |
defaults StaticReadonly | ThematicGradientSettings | ||
margin Accessor StaticReadOnly | number | ||
marginColor Readonly | ColorDef | The margin color used at the extremes of the gradient, when outside the applied range. | |
mode Readonly | ThematicGradientMode | The thematic image mode used to generate the gradient. | |
stepCount Readonly | number | The step count value used for ThematicGradientMode.Stepped, ThematicGradientMode.SteppedWithDelimiter, and ThematicGradientMode.IsoLines. |
Defined in
Last Updated: 20 June, 2023