ImageBuffer Class
Uncompressed rectangular bitmap image data.
Methods
Name | Description | |
---|---|---|
create(data: Uint8Array, format: ImageBufferFormat, width: number): ImageBuffer Static | Create a new ImageBuffer. | |
getNumBytesPerPixel(format: ImageBufferFormat): number Static | Determine the number of bytes allocated to a single pixel for the specified format. |
Properties
Name | Type | Description | |
---|---|---|---|
data Readonly | Uint8Array | Image data in which each pixel occupies 1 or more bytes depending of the ImageBufferFormat. | |
format Readonly | ImageBufferFormat | Format of the bytes in the image. | |
height Accessor ReadOnly | number | Get the height of this image in pixels. | |
numBytesPerPixel Accessor ReadOnly | number | Return the number of bytes allocated for each pixel. | |
width Readonly | number | Width of image in pixels |
Defined in
- core/common/src/Image.ts Line 27
Last Updated: 20 June, 2023