FeatureTable Class
Defines a look-up table for Features within a batched RenderGraphic. Consecutive 32-bit
indices are assigned to each unique Feature. Primitives within the RenderGraphic can
use per-vertex indices to specify the distribution of Features within the primitive. The appearance of individual
features can be customized using FeatureOverrides. Typically a Tile will contain a feature table
identifying the elements whose geometry appears within that tile.
see FeatureOverrides for customizing the appearance of individual features.
Extends
Methods
Name |
Description |
|
constructor(maxFeatures: number, modelId: string = Id64.invalid, type: BatchType = BatchType.Primary): FeatureTable |
Construct an empty FeatureTable. |
|
findFeature(index: number): undefined | Feature |
Returns the Feature corresponding to the specified index, or undefined if the index is not present. |
|
Inherited methods
Name |
Inherited from |
Description |
clear(): void |
IndexMap |
Removes all elements from the map. |
indexOf(value: Feature): number |
IndexMap |
Finds the index of an element equivalent to the supplied value. |
insert(value: Feature, onInsert?: (value: Feature) => any): number |
IndexMap |
Attempt to insert a new value into the map. |
lowerBound(value: Feature): { equal: boolean, index: number } Protected |
IndexMap |
|
toArray(): Feature[] |
IndexMap |
Return an array of the elements in this map in which the array index of each element corresponds to the index assigned to it by the map. |
Properties
Name |
Type |
Description |
|
isPlanarClassifier Accessor ReadOnly |
boolean |
Returns true if this FeatureTable is associated with BatchType.PlanarClassifier geometry. |
|
isUniform Accessor ReadOnly |
boolean |
Returns true if this FeatureTable contains exactly one Feature. |
|
isVolumeClassifier Accessor ReadOnly |
boolean |
Returns true if this FeatureTable is associated with BatchType.VolumeClassifier geometry. |
|
maxFeatures Accessor ReadOnly |
number |
Returns the maximum number of Features this FeatureTable can contain. |
|
modelId Readonly |
string |
|
|
type Readonly |
BatchType |
|
|
uniform Accessor ReadOnly |
undefined | Feature |
If this FeatureTable contains exactly one Feature, returns that Feature; otherwise returns undefined. |
|
Inherited properties
Defined in
Last Updated:
20 June, 2023