RenderGraphic Class
Abstract representation of an object which can be rendered by a RenderSystem. Two broad classes of graphics exist:
- "Scene" graphics generated on the back-end to represent the contents of the models displayed in a Viewport; and
- Decorations created on the front-end to be rendered along with the scene. The latter are produced using a GraphicBuilder.
extensions
Extended by
- MockRender.Graphic
- RenderGraphicOwner
Implements
Methods
Name | Description | |
---|---|---|
constructor(): RenderGraphic | ||
dispose(): void Abstract |
Defined in
Last Updated: 20 June, 2023