ClipStyleProps Interface
Wire format describing a ClipStyle.
see DisplayStyleSettingsProps.clipStyle.
extensions
Properties
Name | Type | Description | |
---|---|---|---|
cutStyle | undefined | CutStyleProps | Controls aspects of how the cut geometry is displayed, if ClipStyleProps.produceCutGeometry is true . |
|
insideColor | undefined | RgbColorProps | If defined, geometry inside the clip planes will be drawn in this color. | |
outsideColor | undefined | RgbColorProps | If defined, geometry outside of the clip planes will be drawn in this color instead of being clipped. | |
produceCutGeometry | undefined | boolean | If true , geometry will be produced at the clip planes in a 3d view. |
Defined in
- core/common/src/ClipStyle.ts Line 105
Last Updated: 20 June, 2023