CutStyleProps Interface
Wire format describing a CutStyle applied to section-cut geometry produced at intersections with a view's ClipVector.
extensions
Properties
Name | Type | Description | |
---|---|---|---|
appearance | undefined | FeatureAppearanceProps | If defined, overrides aspects of the cut geometry's symbology. | |
hiddenLine | undefined | HiddenLine.SettingsProps | If defined, overrides the view's HiddenLine.Settings when drawing the cut geometry. | |
viewflags | undefined | Partial<Mutable<NonFunctionPropertiesOf<ViewFlags>>> | If defined, overrides aspects of the view's ViewFlags when drawing the cut geometry. |
Defined in
- core/common/src/ClipStyle.ts Line 20
Last Updated: 20 June, 2023