CutStyle Class
As part of a ClipStyle, describes how section-cut graphics should be displayed.
note Section-cut graphics are only produced if ClipStyle.produceCutGeometry is true
.
Methods
Name | Description | |
---|---|---|
toJSON(): undefined | CutStyleProps | Return JSON representation. | |
create(viewflags?: Readonly<Partial<Mutable<NonFunctionPropertiesOf<ViewFlags>>>>, hiddenLine?: HiddenLine.Settings, appearance?: FeatureAppearance): CutStyle Static | Create a CutStyle from its components. | |
fromJSON(props?: CutStyleProps): CutStyle Static |
Properties
Name | Type | Description | |
---|---|---|---|
appearance Readonly | undefined | FeatureAppearance | If defined, overrides aspects of the symbology of the section-cut graphics. | |
defaults StaticReadonly | CutStyle | The default CutStyle, configured to draw the section-cut graphics using the view's settings, with no overrides. | |
hiddenLine Readonly | undefined | HiddenLine.Settings | If defined, overrides the settings the view uses to draw the edges of the section-cut graphics. | |
matchesDefaults Accessor ReadOnly | boolean | Returns true if this style matches the default style - that is, it overrides none of the view's settings. | |
viewflags Readonly | Readonly<Partial<Mutable<NonFunctionPropertiesOf<ViewFlags>>>> | Selectively overrides some of the view's ViewFlags when drawing the section-cut graphics. |
Defined in
- core/common/src/ClipStyle.ts Line 33
Last Updated: 20 June, 2023