ChangedEntities Interface
JSON representation of the set of Elements or Models that were changed by a Txn.
see TxnManager.onElementsChanged and TxnManager.onModelsChanged.
see BriefcaseTxns.onElementsChanged and BriefcaseTxns.onModelsChanged.
extensions
Properties
Name | Type | Description | |
---|---|---|---|
deleted | undefined | string | The ids of entities that were deleted during the Txn. | |
inserted | undefined | string | The ids of entities that were inserted during the Txn. | |
updated | undefined | string | The ids of entities that were modified during the Txn, including any Elements for which one of their ElementAspects was changed. |
Defined in
Last Updated: 20 June, 2023