ElementAspect Class
An Element Aspect is a class that defines a set of properties that are related to (and owned by) a single element.
Semantically, an ElementAspect can be considered part of the Element. Thus, an ElementAspect is deleted if its owning Element is deleted.
BIS Guideline: Subclass ElementUniqueAspect or ElementMultiAspect rather than subclassing ElementAspect directly.
Extends
Extended by
Methods
Inherited methods
Name |
Inherited from |
Description |
collectReferenceIds(referenceIds: Set<string>): void Protected |
Entity |
Collect the Ids of this entity's references at this level of the class hierarchy. |
forEachProperty(func: PropertyCallback, includeCustom: boolean = true): void |
Entity |
Call a function for each property of this Entity. |
getReferenceIds(): Set<string> |
Entity |
Get the Ids of this element's references. |
is(otherClass: undefined): boolean Static |
Entity |
return whether this Entity class is a subclass of another Entity class |
Properties
Inherited properties
Name |
Type |
Inherited from |
Description |
classFullName Accessor ReadOnly |
string |
Entity |
Get the full BIS class name of this Entity in the form "schema:class". |
classFullName Accessor StaticReadOnly |
string |
Entity |
Get the full BIS class name of this Entity in the form "schema:class" |
className Accessor ReadOnly |
string |
Entity |
The name of the BIS class associated with this class. |
id |
string |
Entity |
The Id of this Entity. |
iModel |
IModelDb |
Entity |
The IModelDb that contains this Entity |
isInstanceOfEntity Readonly |
"true" |
Entity |
An immutable property used to discriminate between Entity and EntityProps, used to inform the TypeScript compiler that these two types |
schema Static |
undefined |
Entity |
The Schema that defines this class. |
schemaName Accessor ReadOnly |
string |
Entity |
The name of the BIS Schema that defines this class |
Defined in
Last Updated:
20 June, 2023