Entity Class
Represents an entity in an IModelDb such as an Element, Model, or Relationship. Every subclass of Entity represents one BIS ECClass. An Entity is typically instantiated from an EntityProps and can be converted back to this representation via Entity.toJSON.
Extended by
Methods
Name | Description | |
---|---|---|
collectReferenceIds(referenceIds: Set<string>): void Protected | Collect the Ids of this entity's references at this level of the class hierarchy. | Beta |
forEachProperty(func: PropertyCallback, includeCustom: boolean = true): void | Call a function for each property of this Entity. | |
getReferenceIds(): Set<string> | Get the Ids of this element's references. | Beta |
toJSON(): EntityProps | Obtain the JSON representation of this Entity. | |
is(otherClass: undefined): boolean Static | return whether this Entity class is a subclass of another Entity class |
Properties
Name | Type | Description | |
---|---|---|---|
classFullName Accessor ReadOnly | string | Get the full BIS class name of this Entity in the form "schema:class". | |
classFullName Accessor StaticReadOnly | string | Get the full BIS class name of this Entity in the form "schema:class" | |
className Accessor ReadOnly | string | The name of the BIS class associated with this class. | |
className Accessor StaticReadOnly | string | The name of the BIS class associated with this class. | |
id | string | The Id of this Entity. | |
iModel | IModelDb | The IModelDb that contains this Entity | |
isInstanceOfEntity Readonly | "true" | An immutable property used to discriminate between Entity and EntityProps, used to inform the TypeScript compiler that these two types | |
schema Static | undefined | The Schema that defines this class. | |
schemaName Accessor ReadOnly | string | The name of the BIS Schema that defines this class |
Defined in
- backend/src/Entity.ts Line 19
Last Updated: 20 June, 2023