Relationship Class
Base class for all link table ECRelationships
Extends
Extended by
Methods
Name |
Description |
|
delete(): void |
Delete this Relationship from the iModel. |
|
insert(): string |
Insert this Relationship into the iModel. |
|
update(): void |
Update this Relationship in the iModel. |
|
getInstance<T extends Relationship<T>>(iModel: IModelDb, criteria: string | SourceAndTarget): T Static |
|
|
onDeletedDependency(_props: RelationshipProps, _iModel: IModelDb): void Static |
Callback invoked by saveChanges on an ElementDrivesElement relationship when the relationship instance has been deleted. |
|
onRootChanged(_props: RelationshipProps, _iModel: IModelDb): void Static |
Callback invoked by saveChanges on an ElementDrivesElement relationship when its input has changed or is the output of some upstream relationship whose input has changed. |
|
Inherited methods
Name |
Inherited from |
Description |
collectReferenceIds(referenceIds: Set<string>): void Protected |
Entity |
Collect the Ids of this entity's references at this level of the class hierarchy. |
forEachProperty(func: PropertyCallback, includeCustom: boolean = true): void |
Entity |
Call a function for each property of this Entity. |
getReferenceIds(): Set<string> |
Entity |
Get the Ids of this element's references. |
is(otherClass: undefined): boolean Static |
Entity |
return whether this Entity class is a subclass of another Entity class |
Properties
Name |
Type |
Description |
|
sourceId Readonly |
string |
|
|
targetId Readonly |
string |
|
|
Inherited properties
Name |
Type |
Inherited from |
Description |
classFullName Accessor ReadOnly |
string |
Entity |
Get the full BIS class name of this Entity in the form "schema:class". |
classFullName Accessor StaticReadOnly |
string |
Entity |
Get the full BIS class name of this Entity in the form "schema:class" |
className Accessor ReadOnly |
string |
Entity |
The name of the BIS class associated with this class. |
id |
string |
Entity |
The Id of this Entity. |
iModel |
IModelDb |
Entity |
The IModelDb that contains this Entity |
isInstanceOfEntity Readonly |
"true" |
Entity |
An immutable property used to discriminate between Entity and EntityProps, used to inform the TypeScript compiler that these two types |
schema Static |
undefined |
Entity |
The Schema that defines this class. |
schemaName Accessor ReadOnly |
string |
Entity |
The name of the BIS Schema that defines this class |
Defined in
Last Updated:
20 June, 2023