RelationshipProps Interface
Properties that are common to all types of link table ECRelationships
extensions
Extends
Inherited properties
Name | Type | Inherited from | Description |
---|---|---|---|
classFullName | string | EntityProps | The full name of the ECClass for this entity, in the form "Schema:ClassName" |
id | undefined | string | EntityProps | The Id of the entity. |
isInstanceOfEntity Readonly | undefined | undefined | EntityProps | A non-existent property used to discriminate between EntityProps and Entity. |
jsonProperties | undefined | { T } | EntityProps | Optional json properties of this Entity. |
sourceId | string | SourceAndTarget | |
targetId | string | SourceAndTarget |
Defined in
- core/common/src/EntityProps.ts Line 46
Last Updated: 20 June, 2023