DisplayStyleLoadProps Interface
Options controlling which properties are included or excluded when querying DisplayStyleProps.
see ViewStateLoadProps and ElementLoadOptions.
extensions
Properties
Name | Type | Description | |
---|---|---|---|
compressExcludedElementIds | undefined | boolean | If true, DisplayStyleSettingsProps.excludedElements will be compressed into a single compact string; otherwise they will be expanded into an array of strings. | |
omitScheduleScriptElementIds | undefined | boolean | If true, the lists of element Ids in the display style's schedule script will be empty. |
Defined in
- core/common/src/ElementProps.ts Line 338
Last Updated: 20 June, 2023