ElementLoadOptions Interface
Options used to specify properties to include or exclude when querying ElementProps with functions like IModelDb.Elements.getElementProps and IModelConnection.Elements.loadProps.
extensions
Properties
Name | Type | Description | |
---|---|---|---|
displayStyle | undefined | DisplayStyleLoadProps | Options controlling which properties of DisplayStyleProps to include or exclude. | |
onlyBaseProperties | undefined | boolean | if true, only load the members of ElementProps, and no members from subclasses | |
renderTimeline | undefined | RenderTimelineLoadProps | Options controlling which properties of RenderTimelineProps to include or exclude. | |
wantBRepData | undefined | boolean | If true, include BRepEntity.DataProps.data in the GeometryStreamProps for GeometricElementProps and GeometryPartProps. | |
wantGeometry | undefined | boolean | If true, include the GeometryStreamProps for GeometricElementProps and GeometryPartProps. |
Defined in
- core/common/src/ElementProps.ts Line 366
Last Updated: 20 June, 2023