getElementProps Method
Get properties of an Element by Id, FederationGuid, or Code
getElementProps<T extends ElementProps>(props: string | Code | ElementLoadProps): T
throws IModelError if the element is not found or cannot be loaded.
see IModelDb.Elements.tryGetElementProps
Parameter | Type | Description |
---|---|---|
props | string | Code | ElementLoadProps |
Returns - T
Defined in
- backend/src/IModelDb.ts Line 1596
Last Updated: 20 June, 2023