IModelError Class
The error type thrown by this module.
see IModelErrorNumber for commonly-used error codes.
Extends
Extended by
Methods
Name | Description | |
---|---|---|
constructor(errorNumber: number, message: string, getMetaData?: GetMetaDataFunction): IModelError |
Inherited methods
Name | Inherited from | Description |
---|---|---|
_initName(): string Protected | BentleyError | This function returns the name of each error status. |
getMetaData(): undefined | object | BentleyError | get the meta data associated with this BentleyError, if any. |
BentleyError | Use run-time type checking to safely get a useful string summary of an unknown error value, or "" if none exists. |
|
getErrorMetadata(error: unknown): undefined | object Static | BentleyError | Use run-time type checking to safely get the metadata with an unknown error value, if possible. |
getErrorProps(error: unknown): ErrorProps Static | BentleyError | Returns a new ErrorProps object representing an unknown error value. |
getErrorStack(error: unknown): undefined | string Static | BentleyError | Use run-time type checking to safely get the call stack of an unknown error value, if possible. |
getMetaData(metaData: LoggingMetaData): undefined | object Static | BentleyError | get the metadata object associated with an ExceptionMetaData, if any. |
Inherited properties
Name | Type | Inherited from | Description |
---|---|---|---|
errorNumber | number | BentleyError | |
hasMetaData Accessor ReadOnly | boolean | BentleyError | Returns true if this BentleyError includes (optional) metadata. |
Defined in
- core/common/src/IModelError.ts Line 27
Last Updated: 20 June, 2023