NoContentError Class
Intended for API "no content" semantics where the error case should not trigger application failure monitoring systems.
Extends
Methods
Inherited methods
Name |
Inherited from |
Description |
_initName(): string Protected |
IModelError |
This function returns the name of each error status. |
getMetaData(): undefined | object |
IModelError |
get the meta data associated with this BentleyError, if any. |
getErrorMessage(error: unknown): string Static |
IModelError |
Use run-time type checking to safely get a useful string summary of an unknown error value, or "" if none exists. |
getErrorMetadata(error: unknown): undefined | object Static |
IModelError |
Use run-time type checking to safely get the metadata with an unknown error value, if possible. |
getErrorProps(error: unknown): ErrorProps Static |
IModelError |
Returns a new ErrorProps object representing an unknown error value. |
getErrorStack(error: unknown): undefined | string Static |
IModelError |
Use run-time type checking to safely get the call stack of an unknown error value, if possible. |
getMetaData(metaData: LoggingMetaData): undefined | object Static |
IModelError |
get the metadata object associated with an ExceptionMetaData, if any. |
Inherited properties
Defined in
Last Updated:
20 June, 2023