tryGetElementProps Method
Get properties of an Element by Id, FederationGuid, or Code
tryGetElementProps<T extends ElementProps>(elementId: string | Code | ElementLoadProps): undefined | T
throws IModelError if the element exists, but cannot be loaded.
note Useful for cases when an element may or may not exist and throwing an Error
would be overkill.
see IModelDb.Elements.getElementProps
Parameter | Type | Description |
---|---|---|
elementId | string | Code | ElementLoadProps |
Returns - undefined | T
The properties of the element or undefined
if the element is not found.
Defined in
- backend/src/IModelDb.ts Line 1615
Last Updated: 20 June, 2023