ElementProps Interface
Properties of an Element
extensions
Extends
Properties
Name | Type | Description | |
---|---|---|---|
code | CodeProps | The Code for this element | |
federationGuid | undefined | string | A FederationGuid assigned to this element. | |
jsonProperties | undefined | any | Optional json properties of this element. | |
model | string | The Id of the Model containing this element | |
parent | undefined | RelatedElementProps | The Parent of this element, if defined. | |
userLabel | undefined | string | A user-assigned label for this element. |
Inherited properties
Name | Type | Inherited from | Description |
---|---|---|---|
classFullName | string | EntityProps | The full name of the ECClass for this entity, in the form "Schema:ClassName" |
id | undefined | string | EntityProps | The Id of the entity. |
isInstanceOfEntity Readonly | undefined | undefined | EntityProps | A non-existent property used to discriminate between EntityProps and Entity. |
Defined in
- core/common/src/ElementProps.ts Line 35
Last Updated: 20 June, 2023