ElementLoadProps Interface
Parameters to specify what element to load for functions like IModelDb.Elements.getElementProps.
extensions
Extends
Properties
Name | Type | Description | |
---|---|---|---|
code | undefined | CodeProps | The properties of the Code of the element to load. | |
federationGuid | undefined | string | ||
id | undefined | string |
Inherited properties
Name | Type | Inherited from | Description |
---|---|---|---|
displayStyle | undefined | DisplayStyleLoadProps | ElementLoadOptions | Options controlling which properties of DisplayStyleProps to include or exclude. |
onlyBaseProperties | undefined | boolean | ElementLoadOptions | if true, only load the members of ElementProps, and no members from subclasses |
renderTimeline | undefined | RenderTimelineLoadProps | ElementLoadOptions | Options controlling which properties of RenderTimelineProps to include or exclude. |
wantBRepData | undefined | boolean | ElementLoadOptions | If true, include BRepEntity.DataProps.data in the GeometryStreamProps for GeometricElementProps and GeometryPartProps. |
wantGeometry | undefined | boolean | ElementLoadOptions | If true, include the GeometryStreamProps for GeometricElementProps and GeometryPartProps. |
Defined in
- core/common/src/ElementProps.ts Line 388
Last Updated: 20 June, 2023