DisplayStyleModelAppearanceProps Interface
A FeatureAppearanceProps applied to a specific model to override its appearance within the context of a DisplayStyle.
see DisplayStyleSettingsProps.modelOvr.
extensions
Extends
Properties
Name | Type | Description | |
---|---|---|---|
modelId | string | The Id of the model whose appearance is to be overridden. |
Inherited properties
Name | Type | Inherited from | Description |
---|---|---|---|
emphasized | undefined | "true" | FeatureAppearanceProps | See FeatureAppearance.emphasized. |
ignoresMaterial | undefined | "true" | FeatureAppearanceProps | See FeatureAppearance.ignoresMaterial. |
linePixels | undefined | LinePixels | FeatureAppearanceProps | See FeatureAppearance.linePixels. |
nonLocatable | undefined | "true" | FeatureAppearanceProps | See FeatureAppearance.nonLocatable. |
rgb | undefined | RgbColorProps | FeatureAppearanceProps | See FeatureAppearance.rgb. |
transparency | undefined | number | FeatureAppearanceProps | See FeatureAppearance.transparency. |
viewDependentTransparency | undefined | "true" | FeatureAppearanceProps | See FeatureAppearance.viewDependentTransparency. |
weight | undefined | number | FeatureAppearanceProps | See FeatureAppearance.weight. |
Defined in
Last Updated: 20 June, 2023