RealityDataSourceKey Namespace
Beta
RealityDataSourceKey utility functions
Function
Name | Description |
---|---|
RealityDataSourceKey.convertToString | Utility function to convert a RealityDataSourceKey into its string representation |
RealityDataSourceKey.isEqual | Utility function to compare two RealityDataSourceKey, we consider it equal even if itwinId is different |
Defined in
RealityDataSourceKey Interface
Beta
Key used by RealityDataSource to identify provider and reality data format This key identify one and only one reality data source on the provider
Properties
Name | Type | Description | |
---|---|---|---|
format | string | The format used by the provider to store the reality data | |
iTwinId | undefined | string | The context id that was used when reality data was attached - if none provided, current session iTwinId will be used | |
id | string | The reality data id that identify a reality data for the provider | |
provider | string | The provider that supplies the access to reality data source for displaying the reality model |
Defined in
Last Updated: 20 June, 2023