Environment Class
As part of a DisplayStyle3dSettings, controls the display of a SkyBox and GroundPlane to simulate the outdoor environment.
see DisplayStyle3dSettings.environment.
Methods
Name | Description | |
---|---|---|
constructor(props?: Partial<EnvironmentProperties>): Environment Protected | ||
clone(changedProps?: Partial<EnvironmentProperties>): Environment | Create a copy of this environment, identical except for any properties specified by changedProps . |
|
toJSON(): EnvironmentProps | Convert to JSON representation. | |
withDisplay(display: { ground?: boolean, sky?: boolean }): Environment | Create a copy of this environment, changing the displayGround and/or displaySky flags. |
|
create(props?: Partial<EnvironmentProperties>): Environment Static | Create a new Environment. | |
fromJSON(props?: EnvironmentProps): Environment Static | Create from JSON representation. |
Properties
Name | Type | Description | |
---|---|---|---|
defaults StaticReadonly | Environment | Default settings with neither ground plane nor sky box displayed. | |
displayGround Readonly | boolean | If true, the ground plane will be displayed. | |
displaySky Readonly | boolean | If true, the sky box will be displayed. | |
ground Readonly | GroundPlane | Describes how the ground plane should be drawn. | |
sky Readonly | SkyBox | Describes how the sky box should be drawn. |
Defined in
- core/common/src/Environment.ts Line 36
Last Updated: 20 June, 2023