OpenDbKey Interface
A key used to identify an opened IModelDb between the frontend and backend for Rpc and Ipc communications. Keys must be unique - that is there can never be two IModelDbs opened with the same key at any given time. If no key is supplied in a call to open an IModelDb, one is generated and returned. It is only necessary to supply a key if you have some reason to assign a specific value to identify an IModelDb. If you don't supply the key, you must use the returned value for Rpc and Ipc communications.
Properties
Name | Type | Description | |
---|---|---|---|
key Readonly | undefined | string |
Defined in
- core/common/src/IModel.ts Line 141
Last Updated: 20 June, 2023