LightSettingsProps Interface
Wire format for a LightSettings describing lighting for a 3d scene. 3d lighting provides the following lights, all of which are optional:
- A "portrait" light affixed to the camera and pointing directly forward into the scene. Color: white.
- A second directional light. Color: white.
- This can be a solar shadow-casting light, or (when shadows are disabled) a roughly overhead light oriented in view space.
- A pair of hemisphere lights pointing in opposite directions along the world Z axis. Each has its own customizable color.
- An ambient light of any color applied equally to all surfaces. Specular intensity of all lights is controlled separately. Light intensities are typically expressed in [0..1] but can be as large as 5.
see DisplayStyle3dSettingsProps
extensions
Properties
Name | Type | Description | |
---|---|---|---|
ambient | undefined | AmbientLightProps | Ambient light settings. | |
fresnel | undefined | FresnelSettingsProps | Fresnel settings. | |
hemisphere | undefined | HemisphereLightsProps | Hemisphere light settings. | |
numCels | undefined | number | Applies a cel-shaded effect. | |
portrait | undefined | { intensity?: number } | A white portrait light affixed to the camera and pointing directly forward into the scene. | |
solar | undefined | SolarLightProps | Solar light settings. | |
specularIntensity | undefined | number | Specular intensity applied to all lights. |
Defined in
- core/common/src/LightSettings.ts Line 394
Last Updated: 20 June, 2023