SolarLightProps Interface
Wire format for the solar directional light associated with a LightSettingsProps. The light is colored white and oriented in any direction in world coordinates. It will cast shadows if it is above the world XY plane and if the shadows view flag is enabled for the view. By default, the solar light is only applied when shadows are enabled, but can be set to be applied unconditionally.
extensions
Properties
Name | Type | Description | |
---|---|---|---|
alwaysEnabled | undefined | boolean | If true, the light will be applied even when shadows are turned off for the view. | |
direction | undefined | XYZProps | Direction of the light in world coordinates. | |
intensity | undefined | number | Intensity of the light, typically in [0..1] but can range up to 5. | |
timePoint | undefined | number | If defined, the time in UNIX milliseconds from which SolarLightProps.direction was calculated. |
Defined in
- core/common/src/LightSettings.ts Line 25
Last Updated: 20 June, 2023