ExternalSourceAspectProps Interface
Properties of an ExternalSourceAspect that stores synchronization information for an element originating from an external source.
extensions
Extends
Properties
Name | Type | Description | |
---|---|---|---|
checksum | undefined | string | The optional cryptographic hash (any algorithm) of the source object's content. | |
identifier | string | The identifier of the object in the source repository. | |
jsonProperties | undefined | any | A place where additional JSON properties can be stored. | |
kind | string | The kind of object within the source repository. | |
scope | RelatedElementProps | An element that scopes the combination of kind and identifier to uniquely identify the object from the external source. |
|
source | undefined | RelatedElementProps | The source of the imported/synchronized object. | |
version | undefined | string | An optional value that is typically a version number or a pseudo version number like last modified time. |
Inherited properties
Name | Type | Inherited from | Description |
---|---|---|---|
classFullName | string | ElementAspectProps | The full name of the ECClass for this entity, in the form "Schema:ClassName" |
element | RelatedElementProps | ElementAspectProps | |
id | undefined | string | ElementAspectProps | The Id of the entity. |
isInstanceOfEntity Readonly | undefined | undefined | ElementAspectProps | A non-existent property used to discriminate between EntityProps and Entity. |
Defined in
- core/common/src/ElementProps.ts Line 410
Last Updated: 20 June, 2023