ExternalSourceAspect Namespace
Enumeration
Name | Description |
---|---|
ExternalSourceAspect.Kind | Standard values for the Kind property of ExternalSourceAspect . |
Defined in
- backend/src/ElementAspect.ts Line 263
ExternalSourceAspect Class
An ElementMultiAspect that stores synchronization information for an Element originating from an external source.
note The associated ECClass was added to the BisCore schema in version 1.0.2
Extends
Methods
Name | Description | |
---|---|---|
findAllBySource(iModelDb: IModelDb, scope: string, kind: string, identifier: string): { aspectId: string, elementId: string }[] Static | Look up the elements that contain one or more ExternalSourceAspect with the specified Scope, Kind, and Identifier. | |
findBySource(iModelDb: IModelDb, scope: string, kind: string, identifier: string): { aspectId?: string, elementId?: string } Static | Deprecated |
Inherited methods
Name | Inherited from | Description |
---|---|---|
collectReferenceIds(referenceIds: Set<string>): void Protected | ElementMultiAspect | Collect the Ids of this entity's references at this level of the class hierarchy. |
forEachProperty(func: PropertyCallback, includeCustom: boolean = true): void | ElementMultiAspect | Call a function for each property of this Entity. |
getReferenceIds(): Set<string> | ElementMultiAspect | Get the Ids of this element's references. |
is(otherClass: undefined): boolean Static | ElementMultiAspect | return whether this Entity class is a subclass of another Entity class |
onDelete(_arg: OnAspectIdArg): void ProtectedStatic | ElementMultiAspect | Called before an ElementAspect is deleted. |
onDeleted(_arg: OnAspectIdArg): void ProtectedStatic | ElementMultiAspect | Called after an ElementAspect was deleted. |
onInsert(_arg: OnAspectPropsArg): void ProtectedStatic | ElementMultiAspect | Called before a new ElementAspect is inserted. |
onInserted(_arg: OnAspectPropsArg): void ProtectedStatic | ElementMultiAspect | Called after a new ElementAspect was inserted. |
onUpdate(_arg: OnAspectPropsArg): void ProtectedStatic | ElementMultiAspect | Called before an ElementAspect is updated. |
onUpdated(_arg: OnAspectPropsArg): void ProtectedStatic | ElementMultiAspect | Called after an ElementAspect was updated. |
Properties
Name | Type | Description | |
---|---|---|---|
checksum | undefined | string | The cryptographic hash (any algorithm) of the source object's content. | |
identifier | string | The identifier of the object in the source repository. | |
jsonProperties | undefined | string | A place where additional JSON properties can be stored. | |
kind | string | The kind of object within the source repository. | |
scope | RelatedElement | An element that scopes the combination of kind and identifier to uniquely identify the object from the external source. |
|
source | undefined | RelatedElement | The source of the imported/synchronized object. | |
version | undefined | string | An optional value that is typically a version number or a pseudo version number like last modified time. |
Inherited properties
Name | Type | Inherited from | Description |
---|---|---|---|
classFullName Accessor ReadOnly | string | ElementMultiAspect | Get the full BIS class name of this Entity in the form "schema:class". |
classFullName Accessor StaticReadOnly | string | ElementMultiAspect | Get the full BIS class name of this Entity in the form "schema:class" |
className Accessor ReadOnly | string | ElementMultiAspect | The name of the BIS class associated with this class. |
element | RelatedElement | ElementMultiAspect | |
id | string | ElementMultiAspect | The Id of this Entity. |
iModel | IModelDb | ElementMultiAspect | The IModelDb that contains this Entity |
isInstanceOfEntity Readonly | "true" | ElementMultiAspect | An immutable property used to discriminate between Entity and EntityProps, used to inform the TypeScript compiler that these two types |
schema Static | undefined | ElementMultiAspect | The Schema that defines this class. |
schemaName Accessor ReadOnly | string | ElementMultiAspect | The name of the BIS Schema that defines this class |
Defined in
- backend/src/ElementAspect.ts Line 155
Last Updated: 20 June, 2023