ElementAspectProps Interface
Properties of an ElementAspect
extensions
Extends
Properties
Name | Type | Description | |
---|---|---|---|
element | RelatedElementProps |
Inherited properties
Name | Type | Inherited from | Description |
---|---|---|---|
classFullName | string | EntityProps | The full name of the ECClass for this entity, in the form "Schema:ClassName" |
id | undefined | string | EntityProps | The Id of the entity. |
isInstanceOfEntity Readonly | undefined | undefined | EntityProps | A non-existent property used to discriminate between EntityProps and Entity. |
jsonProperties | undefined | { T } | EntityProps | Optional json properties of this Entity. |
Defined in
- core/common/src/ElementProps.ts Line 402
Last Updated: 20 June, 2023