ImageMapLayerProps Interface
JSON representation of an ImageMapLayerSettings.
see MapImagerySettings.
Extends
Properties
Name | Type | Description | |
---|---|---|---|
formatId | string | Identifies the map layers source. | |
subLayers | undefined | MapSubLayerProps[] | Source layers. | |
url | string | URL |
Inherited properties
Name | Type | Inherited from | Description |
---|---|---|---|
name | string | CommonMapLayerProps | A user-friendly name for the layer. |
transparency | undefined | number | CommonMapLayerProps | A transparency value from 0.0 (fully opaque) to 1.0 (fully transparent) to apply to map graphics when drawing, |
transparentBackground | undefined | boolean | CommonMapLayerProps | True to indicate background is transparent. |
visible | undefined | boolean | CommonMapLayerProps | Controls visibility of layer. |
Defined in
- core/common/src/MapLayerSettings.ts Line 151
Last Updated: 20 June, 2023