ImageMapLayerSettings Class
Normalized representation of a ImageMapLayerProps for which values have been validated and default values have been applied where explicit values not defined. Image map layers are created from servers that produce images that represent map tiles. Map layers map also be represented by models. One or more map layers may be included within MapImagerySettings object.
see ModelMapLayerSettings for model based map layer settings.
Extends
Extended by
Methods
Name | Description | |
---|---|---|
clone(changedProps: Partial<ImageMapLayerProps>): ImageMapLayerSettings | Create a copy of this MapLayerSettings, optionally modifying some of its properties. | |
getSubLayerChildren(subLayer: MapSubLayerSettings): undefined | MapSubLayerSettings[] | Return the children for a sublayer | |
isSubLayerVisible(subLayer: MapSubLayerSettings): boolean | Return true if sublayer is visible -- testing ancestors for visibility if they exist. | |
setCredentials(userName?: string, password?: string): void | ||
subLayerById(id?: SubLayerId): undefined | MapSubLayerSettings | Return a sublayer matching id -- or undefined if not found | |
toJSON(): ImageMapLayerProps | return JSON representation of this MapLayerSettings object | |
fromJSON(props: ImageMapLayerProps): ImageMapLayerSettings Static | Create a map layer settings from its JSON representation. |
Properties
Name | Type | Description | |
---|---|---|---|
accessKey | undefined | MapLayerKey | ||
allSubLayersInvisible Accessor ReadOnly | boolean | Return true if all sublayers are invisible. | |
formatId Readonly | string | ||
password | undefined | string | ||
source Accessor ReadOnly | string | ||
subLayers Readonly | MapSubLayerSettings[] | ||
url Readonly | string | ||
userName | undefined | string |
Inherited properties
Name | Type | Inherited from | Description |
---|---|---|---|
name Readonly | string | MapLayerSettings | |
transparency Readonly | number | MapLayerSettings | |
transparentBackground Readonly | boolean | MapLayerSettings | |
visible Readonly | boolean | MapLayerSettings |
Defined in
- core/common/src/MapLayerSettings.ts Line 277
Last Updated: 20 June, 2023