ModelMapLayerSettings Class
Normalized representation of a ModelMapLayerProps for which values have been validated and default values have been applied where explicit values not defined. Model map layers are produced from models, typically from two dimensional geometry that may originate in a GIS system. One or more map layers may be included within MapImagerySettings object.
see ImageMapLayerSettings for image based map layer settings.
Extends
Methods
Name | Description | |
---|---|---|
clone(changedProps: Partial<ModelMapLayerProps>): ModelMapLayerSettings | Create a copy of this MapLayerSettings, optionally modifying some of its properties. | |
toJSON(): ModelMapLayerProps | return JSON representation of this MapLayerSettings object | |
fromJSON(json: ModelMapLayerProps): ModelMapLayerSettings Static | Construct from JSON, performing validation and applying default values for undefined fields. |
Properties
Inherited properties
Name | Type | Inherited from | Description |
---|---|---|---|
name Readonly | string | MapLayerSettings | |
transparency Readonly | number | MapLayerSettings | |
transparentBackground Readonly | boolean | MapLayerSettings | |
visible Readonly | boolean | MapLayerSettings |
Defined in
- core/common/src/MapLayerSettings.ts Line 439
Last Updated: 20 June, 2023