BaseMapLayerSettings Class
A ImageMapLayerSettings that can serve as the base layer for a MapImagerySettings. The base layer supports all of the same options as any other layer, but also allows for simplified configuration based on a small set of known supported BackgroundMapProviders like Bing Maps. If the base layer was configured from such a provider, that information will be preserved and can be queried; this allows the imagery provider and/or type to be easily modified.
see MapImagerySettings.backgroundBase.
Extends
Methods
Name | Description | |
---|---|---|
clone(changedProps: Partial<BaseMapLayerProps>): BaseMapLayerSettings | Create a copy of this layer. | |
toJSON(): BaseMapLayerProps | Convert this layer to its JSON representation. | |
fromJSON(props: BaseMapLayerProps): BaseMapLayerSettings Static | Create a base layer from its JSON representation. | |
fromProvider(provider: BackgroundMapProvider, options?: { invisible?: boolean, transparency?: number }): BaseMapLayerSettings Static | Create a base layer from a BackgroundMapProvider. |
Inherited methods
Name | Inherited from | Description |
---|---|---|
getSubLayerChildren(subLayer: MapSubLayerSettings): undefined | MapSubLayerSettings[] | ImageMapLayerSettings | Return the children for a sublayer |
isSubLayerVisible(subLayer: MapSubLayerSettings): boolean | ImageMapLayerSettings | Return true if sublayer is visible -- testing ancestors for visibility if they exist. |
setCredentials(userName?: string, password?: string): void | ImageMapLayerSettings | |
subLayerById(id?: SubLayerId): undefined | MapSubLayerSettings | ImageMapLayerSettings | Return a sublayer matching id -- or undefined if not found |
Properties
Name | Type | Description | |
---|---|---|---|
provider Accessor ReadOnly | undefined | BackgroundMapProvider | The provider from which this base layer was configured, if any. |
Inherited properties
Name | Type | Inherited from | Description |
---|---|---|---|
accessKey | undefined | MapLayerKey | ImageMapLayerSettings | |
allSubLayersInvisible Accessor ReadOnly | boolean | ImageMapLayerSettings | Return true if all sublayers are invisible. |
formatId Readonly | string | ImageMapLayerSettings | |
name Readonly | string | ImageMapLayerSettings | |
password | undefined | string | ImageMapLayerSettings | |
source Accessor ReadOnly | string | ImageMapLayerSettings | |
subLayers Readonly | MapSubLayerSettings[] | ImageMapLayerSettings | |
transparency Readonly | number | ImageMapLayerSettings | |
transparentBackground Readonly | boolean | ImageMapLayerSettings | |
url Readonly | string | ImageMapLayerSettings | |
userName | undefined | string | ImageMapLayerSettings | |
visible Readonly | boolean | ImageMapLayerSettings |
Defined in
- core/common/src/MapLayerSettings.ts Line 507
Last Updated: 20 June, 2023