BaseMapLayerProps Interface
JSON representation of a BaseMapLayerSettings.
Extends
Properties
Name | Type | Description | |
---|---|---|---|
provider | undefined | BackgroundMapProviderProps |
Inherited properties
Name | Type | Inherited from | Description |
---|---|---|---|
formatId | string | ImageMapLayerProps | Identifies the map layers source. |
name | string | ImageMapLayerProps | A user-friendly name for the layer. |
subLayers | undefined | MapSubLayerProps[] | ImageMapLayerProps | Source layers. |
transparency | undefined | number | ImageMapLayerProps | A transparency value from 0.0 (fully opaque) to 1.0 (fully transparent) to apply to map graphics when drawing, |
transparentBackground | undefined | boolean | ImageMapLayerProps | True to indicate background is transparent. |
url | string | ImageMapLayerProps | URL |
visible | undefined | boolean | ImageMapLayerProps | Controls visibility of layer. |
Defined in
- core/common/src/MapLayerSettings.ts Line 495
Last Updated: 20 June, 2023