CommonMapLayerProps Interface
JSON representation of properties common to both ImageMapLayerProps and ModelMapLayerProps.
see MapImageryProps
Properties
Name | Type | Description | |
---|---|---|---|
name | string | A user-friendly name for the layer. | |
transparency | undefined | number | A transparency value from 0.0 (fully opaque) to 1.0 (fully transparent) to apply to map graphics when drawing, | |
transparentBackground | undefined | boolean | True to indicate background is transparent. | |
visible | undefined | boolean | Controls visibility of layer. |
Defined in
- core/common/src/MapLayerSettings.ts Line 129
Last Updated: 20 June, 2023