SubCategoryAppearance Namespace
Interface
Defined in
SubCategoryAppearance Class
Parameters that define the way geometry on a SubCategory appears.
SubCategoryAppearance describes the intrinsic appearance of geometry belonging to that SubCategory, independent of a particular ViewState.
Aspects of a SubCategory's appearance can be overridden in the context of a particular ViewState through the use of SubCategoryOverrides.
Methods
Properties
Name |
Type |
Description |
|
color Readonly |
ColorDef |
The color of the geometry. |
|
defaults Static |
SubCategoryAppearance |
|
|
fillColor Accessor ReadOnly |
ColorDef |
The fill color of geometry marked as being filled. |
|
fillTransparency Accessor ReadOnly |
number |
A value in the range [0, 1] indicating the fill transparency of the geometry where 0.0 means "fully opaque" and 1.0 means "fully transparent". |
|
invisible Readonly |
boolean |
If true, geometry belonging to this SubCategory is not drawn. |
|
materialId Readonly |
string |
The element ID of the material applied to surfaces, or an invalid ID if no material is specified. |
|
priority Readonly |
number |
The display priority used to control which geometry draws in front of other geometry within a 2D view. |
|
styleId Readonly |
string |
The element ID of the line style used to draw curves, or an invalid ID if no line style is specified. |
|
transparency Readonly |
number |
A value in the range [0, 1] indicating the transparency of the geometry where 0.0 means "fully opaque" and 1.0 means "fully transparent". |
|
weight Readonly |
number |
The line width, in pixels. |
|
Defined in
Last Updated:
20 June, 2023