Name |
Description |
|
_updateMaxGlobalScopeFactor(): void Protected |
|
|
adjustAspectRatio(aspect: number): void |
Adjust the aspect ratio of this ViewState so it matches the supplied value. |
|
allow3dManipulations(): boolean Abstract |
Returns true if ViewTools are allowed to operate in three dimensions on this view. |
|
applyPose(props: ViewPose): ViewState Abstract |
Apply a pose to this view to change the viewed volume. |
|
calculateFocusCorners(): Point3d[] |
|
|
calculateFrustum(result?: Frustum): undefined | Frustum |
Calculate the world coordinate Frustum from the parameters of this ViewState. |
|
computeDisplayTransform(args: ComputeDisplayTransformArgs): undefined | Transform |
Compute the transform applied to a model or element at display time, if any. |
Beta |
computeFitRange(): Range3d Abstract |
Compute a range in CoordSystem.World coordinates that tightly encloses the contents of this view. |
|
equals(other: ViewState): boolean |
Determine whether this ViewState exactly matches another. |
|
forEachModel(func: (model: GeometricModelState) => void): void Abstract |
Execute a function on each viewed model |
|
getAspectRatio(): number |
Get the aspect ratio (width/height) of this view |
|
getAspectRatioSkew(): number |
Get the aspect ratio skew (x/y, usually 1.0) that is used to exaggerate the y axis of the view. |
|
getAuxiliaryCoordinateSystemId(): string |
Get the Id of the auxiliary coordinate system for this ViewState |
|
getCenter(result?: Point3d): Point3d |
Get the point at the geometric center of the view. |
|
getExtents(): Vector3d Abstract |
Get the extents of this view in CoordSystem.World coordinates. |
|
getGlobeRotation(): undefined | Matrix3d |
If the view is not of the project as determined by ViewState.getIsViewingProject then return |
|
getGridOrientation(): GridOrientationType |
Get the grid settings for this view |
|
getGridSettings(vp: Viewport, origin: Point3d, rMatrix: Matrix3d, orientation: GridOrientationType): void |
Populate the given origin and rotation with information from the grid settings from the grid orientation. |
|
getGridSpacing(): Readonly<WritableXAndY> |
|
|
getGridsPerRef(): number |
|
|
getIsViewingProject(): boolean |
Return true if the view is looking at the current iModel project extents or |
|
getModelAppearanceOverride(id: string): undefined | FeatureAppearance |
Query the symbology overrides applied to a model when rendered using this ViewState. |
|
getOrigin(): Point3d Abstract |
Get the origin of this view in CoordSystem.World coordinates. |
|
getRotation(): Matrix3d Abstract |
Get the 3x3 ortho-normal Matrix3d for this view. |
|
getSubCategoryOverride(id: string): undefined | SubCategoryOverride |
Query the symbology overrides applied to geometry belonging to a specific subcategory when rendered using this ViewState. |
|
getTargetPoint(result?: Point3d): Point3d |
Get the target point of the view. |
|
getUpVector(point: Point3d): Vector3d |
|
|
getViewClip(): undefined | ClipVector |
Get the clipping volume for this view, if defined |
|
getViewedExtents(): Range3d Abstract |
Get the extents of this view in CoordSystem.World coordinates. |
|
getXVector(result?: Vector3d): Vector3d |
Get the unit vector that points in the view X (left-to-right) direction. |
|
getYVector(result?: Vector3d): Vector3d |
Get the unit vector that points in the view Y (bottom-to-top) direction. |
|
getZVector(result?: Vector3d): Vector3d |
Get the unit vector that points in the view Z (front-to-back) direction. |
|
hasSameCoordinates(other: ViewState): boolean |
Determine whether this ViewState has the same coordinate system as another one. |
|
is2d(): this is ViewState2d |
Returns true if this ViewState is-a ViewState2d |
|
is3d(): this is ViewState3d Abstract |
Returns true if this ViewState is-a ViewState3d |
|
isDrawingView(): this is DrawingViewState Abstract |
Returns true if this ViewState is-a DrawingViewState |
|
isSheetView(): this is SheetViewState |
Returns true if this ViewState is-a SheetViewState |
|
isSpatialView(): this is SpatialViewState Abstract |
Returns true if this ViewState is-a SpatialViewState |
|
load(): Promise<void> |
Asynchronously load any required data for this ViewState from the backend. |
|
lookAtViewAlignedVolume(volume: Range3d, aspect?: number, options?: MarginOptions & OnViewExtentsError): void |
Look at a volume of space defined by a range in view local coordinates, keeping its current rotation. |
|
lookAtVolume(volume: Readonly<WritableLowAndHighXYZ> | Readonly<WritableLowAndHighXY>, aspect?: number, options?: MarginOptions & OnViewExtentsError): void |
Change the volume that this view displays, keeping its current rotation. |
|
postload(hydrateResponse: HydrateViewStateResponseProps): Promise<void> Protected |
|
|
preload(hydrateRequest: HydrateViewStateRequestProps): void Protected |
Populates the hydrateRequest object stored on the ViewState with: |
|
resetExtentLimits(): void |
Resets the largest and smallest values allowed for the extents of this ViewState to their default values. |
|
savePose(): ViewPose Abstract |
Capture a copy of this view's viewed volume. |
|
setAspectRatioSkew(val: number): void |
Set the aspect ratio skew (x/y) for this view. |
|
setAuxiliaryCoordinateSystem(acs?: AuxCoordSystemState): void |
Set or clear the AuxiliaryCoordinateSystem for this view. |
|
setCategorySelector(categories: CategorySelectorState): void |
Set the CategorySelector for this view. |
|
setCenter(center: Point3d): void |
set the center of this view to a new position. |
|
setDisplayStyle(style: DisplayStyleState): void |
|
|
setExtents(viewDelta: Vector3d): void Abstract |
Set the extents of this view in CoordSystem.World coordinates. |
|
setGridSettings(orientation: GridOrientationType, spacing: Point2d, gridsPerRef: number): void |
Set the grid settings for this view |
|
setOrigin(viewOrg: Readonly<WritableXYAndZ>): void Abstract |
Set the origin of this view in CoordSystem.World coordinates. |
|
setRotation(viewRot: Matrix3d): void Abstract |
Change the rotation of the view. |
|
setRotationAboutPoint(rotation: Matrix3d, point?: Point3d): void |
Set the rotation of this ViewState to the supplied rotation, by rotating it about a point. |
|
setStandardGlobalRotation(id: StandardViewId): void |
Orient this view to one of the StandardView rotations, if the the view is not viewing the project then the |
|
setStandardRotation(id: StandardViewId): void |
Orient this view to one of the StandardView rotations. |
|
setViewClip(clip?: ClipVector): void |
Set or clear the clipping volume for this view. |
|
setupFromFrustum(inFrustum: Frustum, opts?: OnViewExtentsError): ViewStatus |
Initialize the origin, extents, and rotation from an existing Frustum |
|
toJSON(): ViewDefinitionProps |
Convert to JSON representation. |
|
toProps(): ViewStateProps |
Serialize this ViewState as a set of properties that can be used to recreate it via ViewState.createFromProps. |
|
viewsCategory(id: string): boolean |
Determine whether the specified Category is displayed in this view |
|
viewsModel(modelId: string): boolean Abstract |
Returns true if this view displays the contents of a ViewState.Model specified by Id. |
|
createFromProps(_props: ViewStateProps, _iModel: IModelConnection): undefined | ViewState Static |
Create a new ViewState object from a set of properties. |
|