extentLimits
Accessor
Get or set the largest and smallest values allowed for the extents for this ViewState The default limits vary based on the type of view:
- Spatial view extents cannot exceed the diameter of the earth.
- Drawing view extents cannot exceed twice the longest axis of the drawing model's range.
- Sheet view extents cannot exceed ten times the paper size of the sheet. Explicitly setting the extent limits overrides the default limits.
extentLimits: ExtentLimits
see ViewState.resetExtentLimits to restore the default limits.
Returns - ExtentLimits
Setter
Get or set the largest and smallest values allowed for the extents for this ViewState The default limits vary based on the type of view:
- Spatial view extents cannot exceed the diameter of the earth.
- Drawing view extents cannot exceed twice the longest axis of the drawing model's range.
- Sheet view extents cannot exceed ten times the paper size of the sheet. Explicitly setting the extent limits overrides the default limits.
extentLimits(limits: ExtentLimits): void
see ViewState.resetExtentLimits to restore the default limits.
Parameter | Type | Description |
---|---|---|
limits | ExtentLimits |
Returns - void
Defined in
- core/frontend/src/ViewState.ts Line 779
Last Updated: 20 June, 2023