ViewDetails Class
Encapsulates access to optional view details stored in JSON properties.
see ViewDetailsProps for the JSON representation.
see ViewDefinition.details and ViewState.details.
Extended by
Properties
Name | Type | Description | |
---|---|---|---|
aspectRatioSkew Accessor | number | The aspect ratio skew (x/y, usually 1.0) used to exaggerate the y axis of the view. | |
auxiliaryCoordinateSystemId Accessor | string | The Id of the auxiliary coordinate system for the view. | |
clipVector Accessor | undefined | ClipVector | Clipping volume for the view. | |
gridOrientation Accessor | GridOrientationType | The orientation of the view's grid. | |
gridSpacing Accessor | Readonly<WritableXAndY> | The grid spacing for the view. | |
gridsPerRef Accessor | number | The number of grids per ref for the view. | |
maxSkew Static | number | Maximum aspect ratio skew. | |
onClipVectorChanged Readonly | BeEvent<(newClip: undefined | ClipVector) => void> | Event raised just before assignment to the ViewDetails.clipVector property. |
Defined in
- core/common/src/ViewDetails.ts Line 70
Last Updated: 20 June, 2023