ViewDetailsProps Interface
Properties of a ViewDefinitionProps stored as JSON.
see ViewDefinitionProps.jsonProperties.
see ViewDetails3dProps for additional properties specific to 3d views.
extensions
Properties
Name | Type | Description | |
---|---|---|---|
acs | undefined | string | Id of the aux coord system. | |
aspectSkew | undefined | number | Aspect ratio skew (x/y) used to exaggerate the y axis of the view. | |
clip | undefined | ClipVectorProps | Describes the ClipVector applied to the view. | |
gridOrient | undefined | GridOrientationType | Grid orientation. | |
gridPerRef | undefined | number | Default: 10. | |
gridSpaceX | undefined | number | Default: 1.0. | |
gridSpaceY | undefined | number | Default: same as gridSpaceX. |
Defined in
- core/common/src/ViewDetails.ts Line 19
Last Updated: 20 June, 2023