ViewDetails3dProps Interface
Properties of a ViewDefinition3dProps stored as JSON.
see ViewDefinition3dProps.jsonProperties.
extensions
Extends
Properties
Name | Type | Description | |
---|---|---|---|
disable3dManipulations | undefined | boolean | Whether viewing tools are prohibited from operating in 3 dimensions on this view. | |
modelClipGroups | undefined | ModelClipGroupProps[] | Defines how to clip groups of models. |
Inherited properties
Name | Type | Inherited from | Description |
---|---|---|---|
acs | undefined | string | ViewDetailsProps | Id of the aux coord system. |
aspectSkew | undefined | number | ViewDetailsProps | Aspect ratio skew (x/y) used to exaggerate the y axis of the view. |
clip | undefined | ClipVectorProps | ViewDetailsProps | Describes the ClipVector applied to the view. |
gridOrient | undefined | GridOrientationType | ViewDetailsProps | Grid orientation. |
gridPerRef | undefined | number | ViewDetailsProps | Default: 10. |
gridSpaceX | undefined | number | ViewDetailsProps | Default: 1.0. |
gridSpaceY | undefined | number | ViewDetailsProps | Default: same as gridSpaceX. |
Defined in
- core/common/src/ViewDetails.ts Line 58
Last Updated: 20 June, 2023