ElementState Class
The "state" of an Element as represented in a web browser.
extensions
Extends
Extended by
Implements
Methods
Name | Description | |
---|---|---|
constructor(props: ElementProps, iModel: IModelConnection): ElementState | Constructor for EntityState | |
toJSON(): ElementProps | Obtain this element's JSON representation. |
Inherited methods
Name | Inherited from | Description |
---|---|---|
clone(iModel?: IModelConnection): ElementState | EntityState | Make an independent copy of this EntityState |
equals(other: ElementState): boolean | EntityState | Return true if this EntityState is equal to another one. |
Properties
Name | Type | Description | |
---|---|---|---|
code Readonly | Code | The Code for this element | |
federationGuid Readonly | undefined | string | A FederationGuid assigned to this element by some other federated database | |
model Readonly | string | The ModelId of the Model containing this element | |
parent Readonly | undefined | RelatedElement | The parent Element of this, or undefined if no parent. | |
userLabel Readonly | undefined | string | A user-assigned label for this element. |
Inherited properties
Name | Type | Inherited from | Description |
---|---|---|---|
classFullName Accessor StaticReadOnly | string | EntityState | Get full BIS class name of this Entity in the form "SchemaName:ClassName". |
classFullName Readonly | string | EntityState | The full class name in the form "schema:class". |
className Accessor ReadOnly | string | EntityState | The name of the BIS class associated with this class. |
id Readonly | string | EntityState | The Id of this Entity. |
iModel Readonly | IModelConnection | EntityState | The iModel from which this Entity was loaded |
jsonProperties Readonly | { T } | EntityState | Optional json properties of this Entity. |
schemaName Accessor StaticReadOnly | string | EntityState | The name of the BIS schema for this class. |
Defined in
- core/frontend/src/EntityState.ts Line 81
Last Updated: 20 June, 2023