ModelSelectorState Class
The state of a ModelSelector. It holds a set of ids of GeometricModels for a SpatialViewState. It defines the set of ModelStates drawn within the view as a set of IDs.
extensions
Extends
Methods
Name | Description | |
---|---|---|
constructor(props: ModelSelectorProps, iModel: IModelConnection): ModelSelectorState | Constructor for EntityState | |
addModels(arg: Id64Arg): void | Add one or more models to this ModelSelectorState | |
containsModel(modelId: string): boolean | Determine whether this ModelSelectorState includes the specified modelId | |
dropModels(arg: Id64Arg): void | Drop one or more models from this ModelSelectorState | |
equalState(other: ModelSelectorState): boolean | Determine if this model selector is logically equivalent to the specified model selector. | |
has(id: string): boolean | Determine whether this ModelSelectorState includes the specified modelId value | |
load(): Promise<void> | Make sure all models referenced by this ModelSelectorState are loaded. | |
toJSON(): ModelSelectorProps | Obtain this element's JSON representation. |
Inherited methods
Name | Inherited from | Description |
---|---|---|
clone(iModel?: IModelConnection): ModelSelectorState | ElementState | Make an independent copy of this EntityState |
equals(other: ModelSelectorState): boolean | ElementState | Return true if this EntityState is equal to another one. |
Properties
Name | Type | Description | |
---|---|---|---|
models Accessor | Set<string> | The set of ModelIds of this ModelSelectorState | |
name Accessor ReadOnly | string | The name of this ModelSelector |
Inherited properties
Name | Type | Inherited from | Description |
---|---|---|---|
classFullName Accessor StaticReadOnly | string | ElementState | Get full BIS class name of this Entity in the form "SchemaName:ClassName". |
classFullName Readonly | string | ElementState | The full class name in the form "schema:class". |
className Accessor ReadOnly | string | ElementState | The name of the BIS class associated with this class. |
code Readonly | Code | ElementState | The Code for this element |
federationGuid Readonly | undefined | string | ElementState | A FederationGuid assigned to this element by some other federated database |
id Readonly | string | ElementState | The Id of this Entity. |
iModel Readonly | IModelConnection | ElementState | The iModel from which this Entity was loaded |
jsonProperties Readonly | { T } | ElementState | Optional json properties of this Entity. |
model Readonly | string | ElementState | The ModelId of the Model containing this element |
parent Readonly | undefined | RelatedElement | ElementState | The parent Element of this, or undefined if no parent. |
schemaName Accessor StaticReadOnly | string | ElementState | The name of the BIS schema for this class. |
userLabel Readonly | undefined | string | ElementState | A user-assigned label for this element. |
Defined in
Last Updated: 20 June, 2023