AuxCoordSystemState Class
The state of an AuxCoordSystem element in the frontend
extensions
Extends
Extended by
Implements
Methods
Name | Description | |
---|---|---|
constructor(props: AuxCoordSystemProps, iModel: IModelConnection): AuxCoordSystemState | Constructor for EntityState | |
display(context: DecorateContext, options: ACSDisplayOptions): void | ||
drawGrid(context: DecorateContext): void | ||
getOrigin(result?: Point3d): Point3d Abstract | ||
getRotation(result?: Matrix3d): Matrix3d Abstract | get a copy of the rotation matrix for this ACS. | |
isValidForView(view: ViewState): boolean | ||
setOrigin(val: Readonly<WritableXAndY> | Readonly<WritableXYAndZ>): void Abstract | ||
setRotation(val: Matrix3d): void Abstract | ||
toJSON(): AuxCoordSystemProps | Obtain this element's JSON representation. | |
createNew(acsName: string, iModel: IModelConnection): AuxCoordSystemState Static | Create a new AuxCoordSystemState. | |
fromProps(props: AuxCoordSystemProps, iModel: IModelConnection): AuxCoordSystemState Static | ||
isOriginInView(drawOrigin: Point3d, viewport: Viewport, adjustOrigin: boolean): boolean Static | Given an origin point, returns whether the point falls within the view or not. |
Inherited methods
Name | Inherited from | Description |
---|---|---|
clone(iModel?: IModelConnection): AuxCoordSystemState | ElementState | Make an independent copy of this EntityState |
equals(other: AuxCoordSystemState): boolean | ElementState | Return true if this EntityState is equal to another one. |
Properties
Name | Type | Description | |
---|---|---|---|
description | undefined | string | ||
is3d Accessor ReadOnly | boolean | ||
type | number |
Inherited properties
Name | Type | Inherited from | Description |
---|---|---|---|
classFullName Accessor StaticReadOnly | string | ElementState | Get full BIS class name of this Entity in the form "SchemaName:ClassName". |
classFullName Readonly | string | ElementState | The full class name in the form "schema:class". |
className Accessor ReadOnly | string | ElementState | The name of the BIS class associated with this class. |
code Readonly | Code | ElementState | The Code for this element |
federationGuid Readonly | undefined | string | ElementState | A FederationGuid assigned to this element by some other federated database |
id Readonly | string | ElementState | The Id of this Entity. |
iModel Readonly | IModelConnection | ElementState | The iModel from which this Entity was loaded |
jsonProperties Readonly | { T } | ElementState | Optional json properties of this Entity. |
model Readonly | string | ElementState | The ModelId of the Model containing this element |
parent Readonly | undefined | RelatedElement | ElementState | The parent Element of this, or undefined if no parent. |
schemaName Accessor StaticReadOnly | string | ElementState | The name of the BIS schema for this class. |
userLabel Readonly | undefined | string | ElementState | A user-assigned label for this element. |
Defined in
- core/frontend/src/AuxCoordSys.ts Line 64
Last Updated: 20 June, 2023