AuxCoordSystem2dState Class
The state of an AuxCoordSystem2d element in the frontend
extensions
Extends
Implements
Methods
Name | Description | |
---|---|---|
constructor(props: AuxCoordSystem2dProps, iModel: IModelConnection): AuxCoordSystem2dState | Constructor for EntityState | |
getOrigin(result?: Point3d): Point3d | ||
getRotation(result?: Matrix3d): Matrix3d | get a copy of the rotation matrix for this ACS. | |
setOrigin(val: Readonly<WritableXAndY> | Readonly<WritableXYAndZ>): void | ||
setRotation(val: Matrix3d): void | ||
toJSON(): AuxCoordSystem2dProps | Obtain this element's JSON representation. |
Inherited methods
Name | Inherited from | Description |
---|---|---|
clone(iModel?: IModelConnection): AuxCoordSystem2dState | AuxCoordSystemState | Make an independent copy of this EntityState |
display(context: DecorateContext, options: ACSDisplayOptions): void | AuxCoordSystemState | |
drawGrid(context: DecorateContext): void | AuxCoordSystemState | |
equals(other: AuxCoordSystem2dState): boolean | AuxCoordSystemState | Return true if this EntityState is equal to another one. |
isValidForView(view: ViewState): boolean | AuxCoordSystemState | |
createNew(acsName: string, iModel: IModelConnection): AuxCoordSystemState Static | AuxCoordSystemState | Create a new AuxCoordSystemState. |
fromProps(props: AuxCoordSystemProps, iModel: IModelConnection): AuxCoordSystemState Static | AuxCoordSystemState | |
isOriginInView(drawOrigin: Point3d, viewport: Viewport, adjustOrigin: boolean): boolean Static | AuxCoordSystemState | Given an origin point, returns whether the point falls within the view or not. |
Properties
Name | Type | Description | |
---|---|---|---|
angle | number | ||
origin Readonly | Point2d |
Inherited properties
Name | Type | Inherited from | Description |
---|---|---|---|
classFullName Accessor StaticReadOnly | string | AuxCoordSystemState | Get full BIS class name of this Entity in the form "SchemaName:ClassName". |
classFullName Readonly | string | AuxCoordSystemState | The full class name in the form "schema:class". |
className Accessor ReadOnly | string | AuxCoordSystemState | The name of the BIS class associated with this class. |
code Readonly | Code | AuxCoordSystemState | The Code for this element |
description | undefined | string | AuxCoordSystemState | |
federationGuid Readonly | undefined | string | AuxCoordSystemState | A FederationGuid assigned to this element by some other federated database |
id Readonly | string | AuxCoordSystemState | The Id of this Entity. |
iModel Readonly | IModelConnection | AuxCoordSystemState | The iModel from which this Entity was loaded |
is3d Accessor ReadOnly | boolean | AuxCoordSystemState | |
jsonProperties Readonly | { T } | AuxCoordSystemState | Optional json properties of this Entity. |
model Readonly | string | AuxCoordSystemState | The ModelId of the Model containing this element |
parent Readonly | undefined | RelatedElement | AuxCoordSystemState | The parent Element of this, or undefined if no parent. |
schemaName Accessor StaticReadOnly | string | AuxCoordSystemState | The name of the BIS schema for this class. |
type | number | AuxCoordSystemState | |
userLabel Readonly | undefined | string | AuxCoordSystemState | A user-assigned label for this element. |
Defined in
- core/frontend/src/AuxCoordSys.ts Line 306
Last Updated: 20 June, 2023