Name |
Inherited from |
Description |
addInPlace(other: Readonly<WritableXYAndZ>): void |
XYZ |
add x,y,z from other in place. |
addScaledInPlace(other: Readonly<WritableXYAndZ>, scale: number): void |
XYZ |
add (in place) the scaled x,y,z of other |
addXYZInPlace(dx: number = 0.0, dy: number = 0.0, dz: number = 0.0): void |
XYZ |
add to x, y, z parts |
at(index: number): number |
XYZ |
Return the x,y, z component corresponding to 0,1,2. |
cloneAsPoint3d(): Point3d |
XYZ |
Clone strongly typed as Point3d |
distance(other: Readonly<WritableXYAndZ>): number |
XYZ |
Return the distance from this point to other |
distanceSquared(other: Readonly<WritableXYAndZ>): number |
XYZ |
Return squared distance from this point to other |
distanceSquaredXY(other: Readonly<WritableXAndY>): number |
XYZ |
Return squared XY distance from this point to other |
distanceXY(other: Readonly<WritableXAndY>): number |
XYZ |
Return the XY distance from this point to other |
freeze(): Readonly<Point3d> |
XYZ |
Freeze this XYZ |
indexOfMaxAbs(): number |
XYZ |
Return the index (0,1,2) of the x,y,z component with largest absolute value |
isAlmostEqual(other: Readonly<Readonly<WritableXYAndZ>>, tol?: number): boolean |
XYZ |
Returns true if this and other have equal x,y,z parts within Geometry.smallMetricDistance. |
isAlmostEqualMetric(other: Readonly<WritableXYAndZ>): boolean |
XYZ |
equality test with Geometry.smallMetricDistance tolerance |
isAlmostEqualXY(other: Readonly<WritableXAndY>, tol?: number): boolean |
XYZ |
Return true if this and other have equal x,y parts within Geometry.smallMetricDistance. |
isAlmostEqualXYZ(x: number, y: number, z: number, tol?: number): boolean |
XYZ |
Return true if this and other have equal x,y,z parts within Geometry.smallMetricDistance. |
isExactEqual(other: Readonly<WritableXYAndZ>): boolean |
XYZ |
exact equality test. |
magnitude(): number |
XYZ |
Return the sqrt of the sum of squared x,y,z parts |
magnitudeSquared(): number |
XYZ |
Return the sum of squared x,y,z parts |
magnitudeSquaredXY(): number |
XYZ |
Return the sum of squared x,y parts |
magnitudeXY(): number |
XYZ |
Return sqrt of the sum of squared x,y parts |
maxAbs(): number |
XYZ |
Return the largest absolute value of any component |
maxDiff(other: Readonly<WritableXYAndZ>): number |
XYZ |
Return the largest absolute distance between corresponding components |
scaleInPlace(scale: number): void |
XYZ |
Multiply the x, y, z parts by scale. |
scaledVectorTo(other: Readonly<WritableXYAndZ>, scale: number, result?: Vector3d): Vector3d |
XYZ |
Return a multiple of a the (full length) vector from this point to other |
set(x: number = 0, y: number = 0, z: number = 0): void |
XYZ |
Set the x,y,z parts. |
setAt(index: number, value: number): void |
XYZ |
Set value at index 0 or 1 or 2. |
setFrom(other: undefined | Float64Array | Readonly<WritableXAndY> | Readonly<WritableXYAndZ>): void |
XYZ |
Set the x,y,z parts from one of these input types |
setFromJSON(json?: XYZProps): void |
XYZ |
Set the x,y,z properties from one of several json forms: |
setFromPoint3d(other?: Readonly<WritableXYAndZ>): void |
XYZ |
Set the x,y,z parts from a Point3d. |
setFromVector3d(other?: Vector3d): void |
XYZ |
Set the x,y,z parts from a Vector3d |
setZero(): void |
XYZ |
Set the x,y,z parts to zero. |
subtractInPlace(other: Readonly<WritableXYAndZ>): void |
XYZ |
add x,y,z from other in place. |
toArray(): number[] |
XYZ |
Return as an array [x,y,z] |
toFloat64Array(): Float64Array |
XYZ |
Pack the x,y,z values in a Float64Array. |
toJSON(): XYZProps |
XYZ |
Return a JSON object as array [x,y,z] |
toJSONXYZ(): XYZProps |
XYZ |
Return a JSON object as key value pairs {x: value, y: value, z: value} |
unitVectorTo(target: Readonly<WritableXYAndZ>, result?: Vector3d): undefined | Vector3d |
XYZ |
Return a unit vector from this vector to other. |
vectorTo(other: Readonly<WritableXYAndZ>, result?: Vector3d): Vector3d |
XYZ |
Return a (full length) vector from this point to other |
accessX(arg: any, defaultValue?: number): undefined | number Static |
XYZ |
Look for (in order) an x coordinate present as: |
accessY(arg: any, defaultValue?: number): undefined | number Static |
XYZ |
Look for (in order) an x coordinate present as: |
accessZ(arg: any, defaultValue?: number): undefined | number Static |
XYZ |
Look for (in order) an x coordinate present as: |
hasZ(arg: any): arg is Readonly<WriteableHasZ> Static |
XYZ |
Type guard to determine whether an object has a member called "z" |
isAnyImmediatePointType(arg: any): boolean Static |
XYZ |
Test if arg is any of: |
isXAndY(arg: any): arg is Readonly<WritableXAndY> Static |
XYZ |
Type guard for XAndY. |
isXYAndZ(arg: any): arg is Readonly<WritableXYAndZ> Static |
XYZ |
Type guard for XYAndZ. |
x(xyz: undefined | XYZProps, defaultValue: number = 0): number Static |
XYZ |
access x part of XYZProps (which may be .x or [0]) |
y(xyz: undefined | XYZProps, defaultValue: number = 0): number Static |
XYZ |
access x part of XYZProps (which may be .x or [0]) |
z(xyz: undefined | XYZProps, defaultValue: number = 0): number Static |
XYZ |
access x part of XYZProps (which may be .x or [0]) |