isAlmostEqual Method
Returns true if this and other have equal x,y,z parts within Geometry.smallMetricDistance.
isAlmostEqual(other: Readonly<Readonly<WritableXYAndZ>>, tol?: number): boolean
Parameter | Type | Description |
---|---|---|
other | Readonly<Readonly<WritableXYAndZ>> | The other XYAndZ to compare |
tol | number | The tolerance for the comparison. If undefined, use Geometry.smallMetricDistance |
Returns - boolean
Defined in
- geometry3d/Point3dVector3d.ts Line 160
Last Updated: 20 June, 2023